Support » Theme: Libre » PHP warnings

  • Resolved John

    (@dsl225)


    Hello,

    Since a couple of months I’m getting those warnings (site running PHP 5.6.29):

    PHP Warning: Cannot modify header information - headers already sent by (output started at /.../wp-content/themes/libre/header.php:11) in /.../wp-includes/pluggable.php on line XXX (different messages with different line numbers here).

    Any clues?

    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi there John,

    Sometimes this happens if there’s an error made while editing the theme’s files. If you’ve made any changes to the theme files, make a backup of the theme folder so that you can have a copy of those changes for later. Any changes to a theme should be made in a Child Theme to prevent the changes from being lost when the theme is updated.

    Once you’ve made your backup, go ahead and delete the Libre theme from your site, and install it again by downloading it from Appearance > Themes > Add New.

    If everything works as it should, you can start making a child theme if you need to change something about how the theme works. If you’re new to child themes, here are some resources to help:

    http://codex.wordpress.org/Child_Themes

    
https://www.smashingmagazine.com/2016/01/create-customize-wordpress-child-theme/

    Once your changes are completed, you can just activate the child theme.

    Let me know if that helps.

    Hi David, many thanks for your kind feedback!
    You are absolutely right: I was using a (badly) modified footer.php file.
    I’m familiar with child themes but I’m lazy… As this was the only thing I needed to edit I didn’t want to create a child theme just for that.

    And this is my favorite rambling: I really don’t understand why we get a bunch of options in Customizer but nothing for the footer. We are able to change the logo and the tagline but never the footer – although those elements are all part of the site’s identity.

    Anyway, thanks a lot and my problem is now corrected.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP warnings’ is closed to new replies.