Support » Plugin: WordPress Simple Shopping Cart » php warnings

  • Resolved mbeerli

    (@mbeerli)


    with your plugin 4.5.7 I have the following warnings
    several times these 4 lines

    [18-Feb-2022 03:26:00 UTC] PHP Warning:  Trying to access array offset on value of type null in /home/../wp-content/themes/graphene/inc/widgets.php on line 50
    [18-Feb-2022 03:26:00 UTC] PHP Warning:  Undefined array key "wp_paypal_shopping_cart_widgets" in /home/../wp-content/plugins/widget-options/includes/widgets/display.php on line 441
    [18-Feb-2022 03:26:00 UTC] PHP Warning:  Trying to access array offset on value of type null in /home/../wp-content/plugins/widget-options/includes/widgets/display.php on line 441
    [18-Feb-2022 03:26:39 UTC] PHP Warning:  Undefined array key 1 in /home/../wp-content/themes/graphene/inc/widgets.php on line 50

    possibly related to the fix from 4.5.6

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter mbeerli

    (@mbeerli)

    oops and another Fatal error

    [18-Feb-2022 05:54:31 UTC] PHP Fatal error:  Uncaught TypeError: count(): Argument #1 ($value) must be of type Countable|array, null given in /home/../wp-content/plugins/wordpress-simple-paypal-shopping-cart/wp_shopping_cart.php:352
    Stack trace:
    #0 /home/../wp-content/plugins/wordpress-simple-paypal-shopping-cart/wp_shopping_cart_misc_functions.php(14): wpspc_cart_actions_handler()
    #1 /home/../wp-includes/class-wp-hook.php(307): wp_cart_init_handler()
    #2 /home/../wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
    #3 /home/../wp-includes/plugin.php(474): WP_Hook->do_action()
    #4 /home/../wp-settings.php(587): do_action()
    #5 /home/../wp-config.php(90): require_once('/home/beerlimar...')
    #6 /home/../wp-load.php(50): require_once('/home/beerlimar...')
    #7 /home/../wp-blog-header.php(13): require_once('/home/beerlimar...')
    #8 /home/../index.php(17): require('/home/beerlimar...')
    #9 {main}
      thrown in /home/../wp-content/plugins/wordpress-simple-paypal-shopping-cart/wp_shopping_cart.php on line 352
    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, thank you for reporting these issue. For testing purposes, can you test one of WordPress default themes like Twenty Twenty. I am curious to know what happens.

    Thank you.

    Thread Starter mbeerli

    (@mbeerli)

    Testing…
    I do not see it happening with Theme 2020
    But I will do further testings over the weekend and report back.

    • This reply was modified 7 months, 1 week ago by mbeerli.
    • This reply was modified 7 months, 1 week ago by mbeerli.
    Plugin Author mra13

    (@mra13)

    To keep using your current theme, you can add a standard shortcode block to the sidebar widget area and then use the following cart shortcode:

    
    [show_wp_shopping_cart]
    

    You can use any of the standard shortcodes explained on the following page in a standard text or shortcode widget:
    https://www.tipsandtricks-hq.com/ecommerce/simple-wp-shopping-cart-installation-usage-290

    Thread Starter mbeerli

    (@mbeerli)

    Still having the issue with Graphene Theme.
    I also noticed that if I add the widget and then try to click the Delete button, it does not even delete.
    So for now no “WP PayPal Shopping Cart” widget, since the other one works.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, I would get in contact with your theme developer and ask them to investigate this issue further. From what I can tell your theme might not be compatible with WordPress 5.9.1. What PHP version is your server running?

    Kind regards.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘php warnings’ is closed to new replies.