Support » Theme: Hueman » PHP Warning: wp-includes/functions.php on line 1366

  • Resolved Alam Khan

    (@badrealam)


    Hey Alex
    I am getting the following error continuously in my error_log file.
    The same error is being repeated.

    It is so often that the file size exceeds 60GB with the same error per day. My disk space is 60GB i have to delete it continuously by SSH.

    I contact the service provider, but they are saying its not because of any server side bug.

    Can you please help me out, if you are aware of this error.

    The complete line is here:
    [Fri Jan 31 03:37:22 2014] [warn] [client 108.162.225.27] mod_fcgid: stderr: PHP Warning: is_dir(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/var/www/vhosts/bujjon.com/:/tmp/) in /var/www/vhosts/bujjon.com/httpdocs/wp-includes/functions.php on line 1366

Viewing 8 replies - 1 through 8 (of 8 total)
  • It may not be a server bug but this is due to the server’s configuration – specifically:

    open_basedir restriction in effect. File(/) is not within the allowed path(s):

    @esmi
    thanks for your reply.
    can you please give more details on this how to solve this error message.
    Due to this i am having sleepless night :O

    You need to go back to your hosts with the error message. Only they can fix this issue.

    😛
    i had a conversation this is what they said:
    “you need to know what directories your code needs access to to work.”
    hardly any luck…

    Now i need to google it.

    😛

    I had the exact same problem today after moving a website from one server to another. The problem was the setting for “upload_path” in wp_options table (I couldn’t access admin section to change it).

    Mine was set to the old server path, I updated it and it worked.

    Yours should probably be something like /var/www/vhosts/bujjon.com/httpdocs/wp-content/uploads
    (assuming that WP is installed in root). HTH

    Hello,

    Have you solved your problem? I have the same problem but I don’t understand what I should do …

    Thank you in advance,

    What I did was update the setting for “upload_path” in the wp_options table in the database. You’ll have to use PHP MyAdmin to do this.

    Also check your config file to see if you have a setting for the upload folder there which is causing a problem

    Gogster saved the day.
    Wish there was a +1 button here.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘PHP Warning: wp-includes/functions.php on line 1366’ is closed to new replies.