Support » Plugin: Wordfence Security - Firewall & Malware Scan » PHP Warning while using WP CLI

  • Resolved Kevin Brent

    (@kevin-brent)


    While using WP CLI I am getting these warnings when running commands. We are using WP v5.3.2, WordFence v7.4.6, and WP CLI v2.4.0 on WPEngine servers.

    PHP Warning:  fopen(/wp-content/wflogs/rules.php): failed to open stream: No such file or directory in /wp-content/plugins/wordfence/vendor/wordfence/wf-waf/src/lib/waf.php on line 325
    Warning: fopen(s/wp-content/wflogs/rules.php): failed to open stream: No such file or directory in /wp-content/plugins/wordfence/vendor/wordfence/wf-waf/src/lib/waf.php on line 325
    PHP Warning:  flock() expects parameter 1 to be resource, bool given in /wp-content/plugins/wordfence/vendor/wordfence/wf-waf/src/lib/waf.php on line 326
    Warning: flock() expects parameter 1 to be resource, bool given in /wp-content/plugins/wordfence/vendor/wordfence/wf-waf/src/lib/waf.php on line 326
    PHP Warning:  include(/wp-content/wflogs/rules.php): failed to open stream: No such file or directory in /wp-content/plugins/wordfence/vendor/wordfence/wf-waf/src/lib/waf.php on line 328
    Warning: include(/wp-content/wflogs/rules.php): failed to open stream: No such file or directory in /wp-content/plugins/wordfence/vendor/wordfence/wf-waf/src/lib/waf.php on line 328
    PHP Warning:  include(): Failed opening '/wp-content/wflogs/rules.php' for inclusion (include_path='.:/usr/share/php') in /wp-content/plugins/wordfence/vendor/wordfence/wf-waf/src/lib/waf.php on line 328
    Warning: include(): Failed opening '/wp-content/wflogs/rules.php' for inclusion (include_path='.:/usr/share/php') in /wp-content/plugins/wordfence/vendor/wordfence/wf-waf/src/lib/waf.php on line 328
    PHP Warning:  flock() expects parameter 1 to be resource, bool given in /wp-content/plugins/wordfence/vendor/wordfence/wf-waf/src/lib/waf.php on line 329
    Warning: flock() expects parameter 1 to be resource, bool given in /wp-content/plugins/wordfence/vendor/wordfence/wf-waf/src/lib/waf.php on line 329
    PHP Warning:  fclose() expects parameter 1 to be resource, bool given in /wp-content/plugins/wordfence/vendor/wordfence/wf-waf/src/lib/waf.php on line 330
    Warning: fclose() expects parameter 1 to be resource, bool given in /wp-content/plugins/wordfence/vendor/wordfence/wf-waf/src/lib/waf.php on line 330
Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP Warning while using WP CLI’ is closed to new replies.