Support » Plugin: BuddyMeet » PHP Warning while using WP 5.2.3 and BP 5.1.2

  • Resolved HansRuedi Keller

    (@schwarzaufweiss)


    While using BuddyMeet 1.6.0 with WP 5.2.3 and BP 5.1.2 I’ve got a few PHP errors in my log…
    PHP Warning: Invalid argument supplied for foreach() in /home/www-data/<domain>/wp-content/plugins/buddymeet/templates/groups/single/buddymeet/home.php on line 17
    BP itself is using the bp-nouveau templates (no custom bp theme).

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author tdakanalis

    (@tdakanalis)

    Hi,

    I will adress this issue in the upcomming version later this month

    Thanks,
    Themis

    Plugin Author tdakanalis

    (@tdakanalis)

    Hi,

    please update to the just released version (1.7.0).

    Thanks,
    Themis

    Thread Starter HansRuedi Keller

    (@schwarzaufweiss)

    Hi @tdakanalis

    With BuddyMeet 1.7.2 (now based on BuddyPress 6.0.0) I’ve got this warning in my error log…

    Warning: Invalid argument supplied for foreach() in /home/www-data/<domain>/wp-content/plugins/buddymeet/templates/groups/single/buddymeet/home.php on line 21

    Thread Starter HansRuedi Keller

    (@schwarzaufweiss)

    …and also this one:

    Warning: Invalid argument supplied for foreach() in /home/www-data/<domain>/wp-content/plugins/buddymeet/templates/groups/single/buddymeet/home.php on line 17

    Thread Starter HansRuedi Keller

    (@schwarzaufweiss)

    Hi @tdakanalis

    I was on PHP 7.2 with that site and now with 7.3 I’ve got no more warnings!

    Have a good day!

    Plugin Author tdakanalis

    (@tdakanalis)

    Just released version 1.7.3 that finally fixes the warning. Happy to hear php 7.3 also handles it.

    Also added an information message when the user ends the call.

    Thread Starter HansRuedi Keller

    (@schwarzaufweiss)

    @tdakanalis

    Would say 1.7.3 is broken!

    Thread Starter HansRuedi Keller

    (@schwarzaufweiss)

    @tdakanalis

    Parse error: syntax error, unexpected ‘endif’ (T_ENDIF), expecting end of file in /home/www-data/<domain>/wp-content/plugins/buddymeet/templates/groups/single/buddymeet/home.php on line 31

    Plugin Author tdakanalis

    (@tdakanalis)

    Please check the version 1.7.4

    Thread Starter HansRuedi Keller

    (@schwarzaufweiss)

    @tdakanalis

    Working. Thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘PHP Warning while using WP 5.2.3 and BP 5.1.2’ is closed to new replies.