WordPress.org

Forums

PHP Warning: unpack() [<a href='function.unpack'>function.unpack</a>]: Type V: n (9 posts)

  1. outsida
    Member
    Posted 7 years ago #

    Hello,

    my WP 2.5 was already running. But yesterday evening my sister rang me and said that she can't open my blog. I checked it and it was true. When I'm trying open my blog only white page no message nothing.

    I checked the error_log but I don't know what to do.

    [Mon Apr 07 21:39:21 2008] [error] [client 77.6.112.216] PHP Warning: unpack() [<a href='function.unpack'>function.unpack</a>]: Type V: not enough input, need 4, have 0 in /srv/www/vhosts/funny-factory.de/subdomains/wp/httpdocs/wp-includes/gettext.php on line 91
    [Mon Apr 07 21:39:21 2008] [error] [client 77.6.112.216] PHP Warning: unpack() [<a href='function.unpack'>function.unpack</a>]: Type V: not enough input, need 4, have 0 in /srv/www/vhosts/funny-factory.de/subdomains/wp/httpdocs/wp-includes/gettext.php on line 91
    [Mon Apr 07 21:39:54 2008] [error] [client 77.6.112.216] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /srv/www/vhosts/funny-factory.de/subdomains/wp/httpdocs/wp-includes/streams.php on line 66

    It is runnin
    WP 2.5
    PHP 5
    Mysql 5
    Suse 10.1 with Plesk 8.3

    The URL is http://wp.funny-factory.de

  2. hakre
    Member
    Posted 7 years ago #

    Because of some faulty input data your blog falls into an endless loop. To better analyse what is happening, please deactivate all plugins. Looks like that one of your plugins is loading a faulty translation file (mofile, load_textdomain();).

  3. outsida
    Member
    Posted 7 years ago #

    I deleted all Plugins from plugin directory.

    [Wed Apr 09 19:12:09 2008] [error] [client 77.6.116.231] PHP Warning: unpack() [<a href='function.unpack'>function.unpack</a>]: Type V: not enough input, need 4, have 0 in /srv/www/vhosts/funny-factory.de/subdomains/wp/httpdocs/wp-includes/gettext.php on line 91

    still same problem. The problems came first time after I tried to install pear. But nothing else. The pear installation failed...

    Please help me...

  4. outsida
    Member
    Posted 7 years ago #

    I can't open backend. Same problem when trying install a new WP installation on another domain at the same server. It seems to be a server Problem. But which problem...

  5. fmurga
    Member
    Posted 7 years ago #

    Plugins are not the problem. It happened to me too. If you are using a language other than English, I suggest you edit you wp-config.php file.

    It looks something like this:

    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', 'es_ES');

    And this is how it should look:

    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    I'm not really sure why, but it seems that WordPress is having problems with language packs.....

    Anyways, I just installed Ver 2.5 with Spanish pack and it is working. I'll keep you posted if something goes wrong.

  6. thomas_brx
    Member
    Posted 6 years ago #

    I had the same problem. In the end it turned out to be a php-configuration issue. The magic_quotes_runtime was set to On in the php.ini file. When changed to Off everything works again.

    magic_quotes_runtime works by adding backslashes in content read from external sources, like textfiles, effectively destroying binary input like an .mo-file, and also destroying configuration-settings read from the database...

  7. TMorph
    Member
    Posted 6 years ago #

    OK language pack spanish

    Solution

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', 'es_ES');
    //define ('WPLANG', '');

    wp-includes/languages spanish files, run OK

    My English is not good, I write with translator, I'm sorry

  8. zupers
    Member
    Posted 6 years ago #

    Guys I've the same problem and have magic_quotes_runtime set to off by default... any solution available yet?

    Is it for the language pack? As you stated?

  9. solotwin
    Member
    Posted 6 years ago #

    Take the mo file out of its folder and put it directly in the folder /languages.
    It work for me.

Topic Closed

This topic has been closed to new replies.

About this Topic