Support » Plugin: EWWW Image Optimizer » PHP Warning: preg_match_all(): Empty regular expression in…

  • Resolved pedrorafael

    (@pedrorafael)


    Hi,

    after updating to the latest version I get constant errors and leaving the site very slow … Logs:

    [Tue Apr 09 15:09:27.874168 2019] [proxy_fcgi:error] [pid 8927:tid 140052588021504] [client 172.68.24.28:0] AH01071: Got error ‘PHP message: PHP Warning: preg_match_all(): Empty regular expression in /home/0007/webapps/mysite/wp-content/plugins/ewww-image-optimizer/classes/class-ewwwio-page-parser.php on line 53’, referer: https://mysite.com/carrinho/
    [Tue Apr 09 15:09:30.172871 2019] [proxy_fcgi:error] [pid 8483:tid 140052508178176] [client 172.68.24.28:0] AH01071: Got error ‘PHP message: PHP Warning: preg_match_all(): Empty regular expression in /home/0007/webapps/mysite/wp-content/plugins/ewww-image-optimizer/classes/class-ewwwio-page-parser.php on line 53’, referer: https://mysite.com/planos/
    [Tue Apr 09 15:09:33.175733 2019] [proxy_fcgi:error] [pid 8927:tid 140052331996928] [client 172.68.24.28:0] AH01071: Got error ‘PHP message: PHP Warning: preg_match_all(): Empty regular expression in /home/0007/webapps/mysite/wp-content/plugins/ewww-image-optimizer/classes/class-ewwwio-page-parser.php on line 53’, referer: https://mysite.com/
    [Tue Apr 09 15:09:55.793513 2019] [proxy_fcgi:error] [pid 8482:tid 140052604806912] [client 127.0.0.1:0] AH01071: Got error ‘PHP message: PHP Warning: preg_match_all(): Empty regular expression in /home/0007/webapps/mysite/wp-content/plugins/ewww-image-optimizer/classes/class-ewwwio-page-parser.php on line 53’, referer: https://mysite.com/
    [Tue Apr 09 15:10:49.048655 2019] [proxy_fcgi:error] [pid 8927:tid 140052206171904] [client 172.68.25.154:0] AH01071: Got error ‘PHP message: PHP Warning: preg_match_all(): Empty regular expression in /home/0007/webapps/mysite/wp-content/plugins/ewww-image-optimizer/classes/class-ewwwio-page-parser.php on line 53’, referer: https://mysite.com/carrinho/
    [Tue Apr 09 15:10:51.590812 2019] [proxy_fcgi:error] [pid 8927:tid 140051493152512] [client 172.68.25.154:0] AH01071: Got error ‘PHP message: PHP Warning: preg_match_all(): Empty regular expression in /home/0007/webapps/mysite/wp-content/plugins/ewww-image-optimizer/classes/class-ewwwio-page-parser.php on line 53’, referer: https://mysite.com/planos/
    [Tue Apr 09 15:10:54.858329 2019] [proxy_fcgi:error] [pid 8927:tid 140052621592320] [client 172.68.25.154:0] AH01071: Got error ‘PHP message: PHP Warning: preg_match_all(): Empty regular expression in /home/0007/webapps/mysite/wp-content/plugins/ewww-image-optimizer/classes/class-ewwwio-page-parser.php on line 53’, referer: https://mysite.com/
    [Tue Apr 09 15:15:18.710643 2019] [proxy_fcgi:error] [pid 8927:tid 140052197779200] [client 127.0.0.1:0] AH01071: Got error ‘PHP message: PHP Warning: preg_match_all(): Empty regular expression in /home/0007/webapps/mysite/wp-content/plugins/ewww-image-optimizer/classes/class-ewwwio-page-parser.php on line 53’, referer: https://mysite.com/
    [Tue Apr 09 15:15:19.005849 2019] [proxy_fcgi:error] [pid 8927:tid 140052604806912] [client 127.0.0.1:0] AH01071: Got error ‘PHP message: PHP Warning: preg_match_all(): Empty regular expression in /home/0007/webapps/mysite/wp-content/plugins/ewww-image-optimizer/classes/class-ewwwio-page-parser.php on line 53’, referer: https://mysite.com/
    [Tue Apr 09 15:15:19.363877 2019] [proxy_fcgi:error] [pid 8481:tid 140051912558336] [client 127.0.0.1:0] AH01071: Got error ‘PHP message: PHP Warning: preg_match_all(): Empty regular expression in /home/0007/webapps/mysite/wp-content/plugins/ewww-image-optimizer/classes/class-ewwwio-page-parser.php on line 53’, referer: https://mysite.com/

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author nosilver4u

    (@nosilver4u)

    Any chance you can get a trace on that? As it is, I’ve no idea how in the world the regex could ever be empty by the time you hit line 53 of that file. But a trace might shed some light on it.

    Plugin Author nosilver4u

    (@nosilver4u)

    Nevermind, I was looking at the wrong line somehow. I know exactly why that error slipped in, and it will be fixed in the next release.
    I actually already fixed it on GitHub without realizing that it was the exact error you were having: https://docs.ewww.io/article/73-update-from-github

    Hi,

    how nice that you have identified the problem!

    The coolest thing about this problem is that it has been able to take a dedicated server out of the air in which I test and pre-upgrade my clients … 🙂

    Good thing it worked and your plugin is very good, will always be present in the projects of my clients.

    See you later!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.