Support » Plugin: Media Library Assistant » PHP Warning on media upload with Polylang

  • Resolved Ulrich

    (@grapplerulrich)


    When running MLA 2.62 and Polylang 2.1.6 with a default theme I get the following PHP warning.

    Warning: array_search() expects parameter 2 to be array, string given in media-library-assistant/includes/class-mla-polylang-support.php on line 407

    Thank you for looking into this 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author David Lingren

    (@dglingren)

    Thanks for your report. I am traveling until 10/26 but I will investigate this as soon as I am back at my development system.

    Plugin Author David Lingren

    (@dglingren)

    I have found and fixed the problem you reported and a small separate problem in mapping hierarchical taxonomy terms during uploads.

    I have uploaded a new MLA Development Version dated 20171026 that contains the fixes. It would be a great help if you can install the Development Version and example plugin and do some testing of your own.

    To get the Development Version, click this link to download the Development Version ZIP archive:

    https://downloads.wordpress.org/plugin/media-library-assistant.zip

    Once you have the ZIP archive on your system:

    1. Login to your site’s Admin area and navigate to Plugins/Installed Plugins.
      Find Media Library Assistant and deactivate it.
    2. Find Media Library Assistant and delete it. You will not lose any settings.
    3. Go to Plugins/Add New.
    4. Click “Upload Plugin”, to the right of the Add Plugins title.<br>”Browse…” to the location of the ZIP Archive and click on it.
    5. Click “Install Now”, to the right of “Browse…”
    6. When the install completes, click “Activate Plugin” at the bottom of the screen.
    7. When the activation completes, go back to the Plugins/Installed Plugins screen.
    8. Scroll down to “Media Library Assistant” and look for a date like “20170604” at the start of the Description. That’s how you know you have a Development Version. You can also go to the Settings/Media Library Assistant submenu and see the date stamp in the heading.

    That’s it. I don’t change the version number of the Development Version, so you will be notified when the next official version comes out and the normal update process will continue to work.

    Ulrich

    (@grapplerulrich)

    HI David

    Sorry for the delayed response. I only got around to testing it today. There was no more PHP warning when uploading an image when using dev version 20171102.

    Thanks!

    Ulrich

    Plugin Author David Lingren

    (@dglingren)

    Thanks for your update with the good news. The fix will be in the next official MLA version.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP Warning on media upload with Polylang’ is closed to new replies.