Support » Plugin: MailPoet - emails and newsletters in WordPress » PHP Warning message for set_time_limit()

  • Peter_Young

    (@oils4painting)


    I have WP_DEBUG enabled and see the following warning message issued every 21 seconds when the MailPoet plugin is Active:
    PHP Warning: set_time_limit(): Cannot set max execution time limit due to system policy in /wp-content/plugins/mailpoet/lib/Cron/DaemonHttpRunner.php on line 31

    The code in DaemonHttpRunner.php states…
    if(strpos(@ini_get(‘disable_functions’), ‘set_time_limit’) === false) {
    set_time_limit(0);
    }

    Could you please explain why this warning message is issued, and if it can be resolved. Note, PHP is at v7.2.
    Thank you,
    Peter Young

Viewing 5 replies - 1 through 5 (of 5 total)
  • Peter Smits

    (@psmits1567)

    Hi Peter,

    I see the same message so are also interested in the answer. The mails are sent properly so it does not seem to be a problem.
    Regards,
    Peter

    Plugin Author MailPoet

    (@wysija)

    Hi Peter and Peter,

    Don’t worry, this isn’t anything to worry about and MailPoet will still send emails.

    Essentially we try and set a time limit if possible so there aren’t timing out issues, however, sometimes this isn’t possible due to the system configuration.

    I’ll report the issue to our developers to see if we can prevent creating the warning.

    Thanks!

    Peter Smits

    (@psmits1567)

    Thanks for your answer.
    As this is not an error, maybe a parameter can be introduced. Because when debugging I would only like to see errors.
    I have commented out the statement to prevent large debug files.
    Regards,

    Hello MailPoet Support,
    Thank you for your reply. I’ll look forward to a fix for this problem, to tidy up the Debug log.
    Thank you,
    Peter Young

    This problem is still occuring, and creating about 4,000 lines per day in the WP_DEBUG log. Are you able to resolve this problem as it is proving difficult to identify other issues?
    Thank you,
    Peter Young

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.