Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » PHP Warning: Invalid argument – in “settings” menu

  • axwellion

    (@axwellion)


    I just installed the free version of Give 1.6.2, and successfully created a donate page. But when I attempt to go to the settings menu to set up my payment gatway, I get the following error.
    PHP Warning: Invalid argument supplied for foreach() in D:\INETPUB\VHOSTS\bolivianswithoutdisabilities.org\httpdocs\wp-content\plugins\give\includes\admin\class-give-settings.php on line 1139

    Consequently I can’t move my donate page out of Test mode because it throws the same error (I assumed this was due to the fact that I did not complete the gateway settings). You can see my donate page here:
    http://bolivianswithoutdisabilities.org/donations/now/

    Can anyone tell me if there is something I can do so that I can get into the Settings menu?
    Thanks
    Matt

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hi Matt,

    This sounds like a plugin or theme conflict.

    Please deactivate all plugins besides GIVE. If it works as expected then re-activate each plugin one at a time until you see the problem again. Then let us know which plugin caused the error and we’ll dig into it.

    If after deactivating all other plugins it still does not work correctly, then tell us where we can get a copy of your theme to test.

    Let me know how that goes.

    axwellion

    (@axwellion)

    Thanks for your quick response Matt. I only had 3 other plugins running, so I deactivated them and then tried to go to the Give settings and got the same PHP warning.
    My theme is Enigma-ProVersion: 2.3
    But I am not sure how to send it to you.
    Thanks
    Matt

    Plugin Contributor GiveWP

    (@givewp)

    Try this, please install this plugin: https://wordpress.org/plugins/send-system-info/

    Go to “Tools > System Info” and download the text file (or create a link from your site, whichever you prefer) and provide that for me here as a link. That will help me understand a bit about your server environment. It’s possible your server has very outdated tech.

    Thanks!

    axwellion

    (@axwellion)

    Creating a link did not work and I don’t know how to attached the text file, so Here is the system info:
    // Generated by the Send System Info Plugin //

    Multisite: No

    SITE_URL: http://bolivianswithoutdisabilities.org
    HOME_URL: http://bolivianswithoutdisabilities.org

    WordPress Version: 4.6.1
    Permalink Structure: /%postname%/
    Active Theme: Enigma-Pro 2.3

    Registered Post Stati: publish, future, draft, pending, private, trash, auto-draft, inherit, refunded, failed, revoked, cancelled, abandoned

    Platform: Windows
    Browser Name: Chrome
    Browser Version: 53.0.2785.143
    User Agent String: Mozilla/5.0 (Windows NT 10.0; Wi
    n64; x64) AppleWebKit/537.36 (KH
    TML, like Gecko) Chrome/53.0.278
    5.143 Safari/537.36

    PHP Version: 5.3.28
    MySQL Version: 5.5.30
    Web Server Info: Microsoft-IIS/7.5

    WordPress Memory Limit: 40MB
    PHP Safe Mode: Yes
    PHP Memory Limit: 256M
    PHP Upload Max Size: 26M
    PHP Post Max Size: 22M
    PHP Upload Max Filesize: 26M
    PHP Time Limit: 60
    PHP Max Input Vars: 1000
    PHP Arg Separator: &
    PHP Allow URL File Open: Yes
    WP_DEBUG: Disabled

    WP Table Prefix: Length: 3 Status: Acceptable

    Show On Front: page
    Page On Front: Home (#4)
    Page For Posts: News (#15)

    WP Remote Post: wp_remote_post() works

    Session: Disabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: C:\Windows\Temp
    Use Cookies: On
    Use Only Cookies: On

    DISPLAY ERRORS: N/A
    FSOCKOPEN: Your server supports fsockopen.
    cURL: Your server supports cURL.
    SOAP Client: Your server has the SOAP Client enabled.
    SUHOSIN: Your server does not have SUHOSIN installed.

    ACTIVE PLUGINS:

    Give – Donation Plugin: 1.6.2
    Send System Info: 1.2
    Wordfence Security: 6.2.2

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    CAn you reach out to me via our Contact form? I think I can help you better over there:
    https://givewp.com/contact

    Thanks!

    axwellion

    (@axwellion)

    When I went to https://givewp.com/contact and was redirected to https://givewp.com/contact-us/
    And then on the https://givewp.com/contact-us/ page, after selecting “I have a support request for Give Core plugin”, I received the following message:
    We’re sorry. All support for the free Give Core plugin is handled over at the WordPress Repository. We do not take requests for Support through this form or by email. Thank you for your patience and understanding.
    Did I go to the wrong support page?
    Thanks

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Sorry, that’s correct, choose “Sending credentials” but don’t give credentials, just want to start the conversation over there. Thanks!

    axwellion

    (@axwellion)

    Ok, done. I presume I will wait until your next message.
    Thanks

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hi @axwellion

    Looks like there’s a small issue that’s affecting your install because your theme doesn’t register any intermediate image sizes at all. I’ve opened an issue here and already have a fix. You can track progress on that here, it’s slated to go into 1.6.4 or 1.7:

    https://github.com/WordImpress/Give/issues/1163

    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘PHP Warning: Invalid argument – in “settings” menu’ is closed to new replies.