Support » Plugin: CMS Page Order » PHP Warning: Declaration of PO_Walker::start_el

  • Since I switched from PHP 5.6 to 7.1 I’ve got errors in the log:

    [Sun Mar 12 07:33:06 2017] [warn] [client 144.76.29.162] mod_fcgid: stderr: PHP Warning: Declaration of PO_Walker::end_lvl(&$output, $depth) should be compatible with Walker_Page::end_lvl(&$output, $depth = 0, $args = Array) in /var/www/vhosts/hosting11009.af93d.netcup.net/httpdocs/wordpress/wp-content/plugins/cms-page-order/cms-page-order.php on line 0

    [Sun Mar 12 07:33:06 2017] [warn] [client 144.76.29.162] mod_fcgid: stderr: PHP Warning: Declaration of PO_Walker::start_el(&$output, $page, $depth, $args) should be compatible with Walker_Page::start_el(&$output, $page, $depth = 0, $args = Array, $current_page = 0) in /var/www/vhosts/hosting11009.af93d.netcup.net/httpdocs/wordpress/wp-content/plugins/cms-page-order/cms-page-order.php on line 0

    I googeled and found the reason:
    Error Warning: Declaration of description_walker::start_el after PHP upgrade
    http://wordpress.stackexchange.com/questions/249007/error-warning-declaration-of-description-walkerstart-el-after-php-upgrade

    First I thought that the reason was the theme Senses Lite.

    The error message comes from the plugin CMS Page Order. There is the bug in the file cms-page-order.php.

    How to fix:
    Please check the link, there you find how to fix it.

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP Warning: Declaration of PO_Walker::start_el’ is closed to new replies.