Support » Plugin: All In One WP Security & Firewall » PHP Warning: Cannot modify header information

  • Resolved krazykatz911

    (@krazykatz911)


    I was getting this repeated PHP error on all my sites and very high memory usage. Once I deactivated this plug in, the errors stopped and memory good.

    Here is the error code:

    PHP Warning: Cannot modify header information - headers already sent by (output started at /home/site/public_html/wp-cron.php:28) in /home/site/public_html/wp-includes/functions.php on line 6029

    Need a fix….

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi,

    I was getting this repeated PHP error on all my sites and very high memory usage. Once I deactivated this plug in, the errors stopped and memory good.

    Are you using the same theme and plugins in all your sites?

    Thread Starter krazykatz911

    (@krazykatz911)

    I have 10 sites, different themes. They were all experiencing this until I deactivated this plug in.

    • This reply was modified 1 year, 9 months ago by krazykatz911.
    Plugin Contributor mbrsolution

    (@mbrsolution)

    Do all the sites run in the same server, or different servers? If it is the same server, what are your server specs?

    If they run in different servers, can you carry out the following troubleshooting steps for one of the sites.

    Disable all Firewall rules in the plugin, then carry out a test.

    Let me know what happens.

    Thank you

    • This reply was modified 1 year, 9 months ago by mbrsolution.
    Thread Starter krazykatz911

    (@krazykatz911)

    Its all on the same server. 8 cores, 6gig memory.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Go to Tools -> Site Health -> Status in the admin panel of one of the sites. Let me know what it says?

    Thank you

    Thread Starter krazykatz911

    (@krazykatz911)

    17 items with no issues detected. All ok

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Okay, lets try something different.

    Do the following in one of the sites. Deactivate all of your other plugin except ours. Then carry out a test? If this does not help, test one of WordPress default themes like Twenty Nineteen. Let me know what happens.

    Also do you have the latest WordPress version running? Are all of your plugins, theme up to date?

    Thank you

    • This reply was modified 1 year, 9 months ago by mbrsolution.
    Thread Starter krazykatz911

    (@krazykatz911)

    I disabled all plugins on my sites, with just All in one running and error was happening. I just removed it from all my sites. I really don’t have time to start making test sites, etc.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, sorry I was not able to help you further.

    I am marking this thread as resolved since you are no longer running our plugin in your sites.

    Kind regards

    Thread Starter krazykatz911

    (@krazykatz911)

    Ok, I researched this more and more, and found that this setting:
    Enable iFrame Protection

    When enabled causes this repeated error. With it disabled, errors stop.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Thank you for reporting back.

    It is interesting to know that the following feature Enable iFrame Protection is causing your issue. I am wondering if a plugin or theme is using iFrame in your site?

    However, at least you now know what feature doesn’t work in your site.

    Well done.

    @krazykatz911 Thank You very much!!!!

    The same error on my sites – after disabling iFrame Protection in All in One the errors disappear.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘PHP Warning: Cannot modify header information’ is closed to new replies.