Support » Plugin: WooCommerce » PHP Warning: A non-numeric value encountered in … class-woocommerce.php …

  • Resolved doffine

    (@doffine)


    Dear Sir or Madam,

    we just updated WooCommerce on three of our shops to version 3.3.1. WordPress is newest 4.9.4. PHP is 7.1. After letting WooCommerce update the database, in two of the three Shops there are two PHP errors in the backend and two in the frontend.

    Backend:
    – Warning: A non-numeric value encountered in /<PATH>/wp-content/plugins/woocommerce/includes/class-woocommerce.php on line 549

    – Warning: Cannot modify header information – headers already sent by (output started at /<PATH>/wp-content/plugins/woocommerce/includes/class-woocommerce.php:549) in /<PATH>/wp-admin/includes/misc.php on line 1114

    Frontend:
    – Warning: A non-numeric value encountered in /<PATH>/wp-content/plugins/woocommerce/includes/class-woocommerce.php on line 549

    To test it out, we switched off all plugins but WooCommerce itself but the error persisted.

Viewing 9 replies - 1 through 9 (of 9 total)
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘PHP Warning: A non-numeric value encountered in … class-woocommerce.php …’ is closed to new replies.