Support » Plugin: HandL UTM Grabber » PHP Warning

  • Resolved John

    (@jemoreto)


    Hello guys! How’re you doing?

    Please, I’m getting hundreds of PHP Warnings in debug.log:

    [29-Dec-2019 13:49:07 UTC] PHP Warning: Cannot modify header information – headers already sent in …/public_html/wp-content/plugins/handl-utm-grabber/handl-utm-grabber.php on line 52

    Does anyone here already experienced this?

    WordPress 5.3.2. Multisite installation. Hosted on Cloudways.com (Amazon server).
    HandL UTM Grabber version 2.7.1.

    Thank you!!

Viewing 2 replies - 1 through 2 (of 2 total)
  • citywanderer

    (@citywanderer)

    Hey! Any movement on this? The warnings are filling up my logs too

    Plugin Author Haktan Suren

    (@haktansuren)

    Hi @jemoreto ,

    you should not see such errors in normal scenario. I think there is either other pluginor your theme might be causing this unexpected warning. For setting the cookie, plugin is using init hook. By the definition (https://developer.wordpress.org/reference/hooks/init/), there should be no other headers sent/printed before this hook in a good practice. But apparently, in your case, something gets printed before the init hook. I recommend you to disable the plugins one by one to find out what causing it. Or try switching the theme as well.

    @citywanderer please see the answer as well.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP Warning’ is closed to new replies.