• Warning: Illegal string offset ‘_alm_prev_post_scroll’ in …wp-content/plugins/ajax-load-more-previous-post/ajax-load-more-previous-post.php on line 464

    This warning appears on a single post with repeating template.

    Doesn’t seem to have an effect on functionality.

    Running PHP version 7.2.19

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author dcooney


    @yellowboxtenant Can you please goto Ajax Load More > Settings and make a change to save the global settings. You can revert after it saves.

    This warning appears when WP_DEBUG is TRUE and settings have not be saved.

    I need to fix this up soon.

    @dcooney Thank you. Made a change to global settings, watched it save, and changed the setting back. Warning is still appearing FYI.

    Plugin Author dcooney


    hmm, maybe you actually have to change the value in the Scroll Top setting of Single Posts.

    @dcooney Thank you for the suggestion. That did not work either.

    Plugin Author dcooney


    Damn, unfortunately that has always fixed that issue.

    The issue is this line:
    $single_post_enable_scroll = (isset($options['_alm_prev_post_scroll'])) ? $options['_alm_prev_post_scroll'] : 'false';

    Are you running the latest version of the add-on?

    Ajax Load More v5.1.7.1
    Ajax Load More: Custom Repeaters v2 Version 2.5.4
    Ajax Load More: SEO Version 1.9.1
    Ajax Load More: Single Post Version 1.4.1

    Just noticing now that our production version of this site does not show any indication that we are behind on versions for the add-ons, but our development mirror shows “There is a new version of…” for each of the add-ons. We can’t update on the development version because our license only applies to our production address. But I don’t see any way to update production because there’s no newer available version message on the plugins page.

    We have license keys for Custom Repeaters, SEO, and Single Posts.

    Plugin Author dcooney


    You’ll only see the warning if WP_DEBUG is True, which would not be the case on production.

    Even still, after saving that error should disappear.

    Looks like you are a point version behind, not sure if that would resolve the issue though.

    I’ve added this my issue list to try and replicate.

    @dcooney Ok thanks for adding it. We aren’t very concerned about it.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.