Support » Plugin: WP-Members Membership Plugin » PHP Warning

  • Resolved svacontact

    (@svacontact)


    Hi,

    I’m seeing a new PHP “warning” in the server log for version 3.18 as follows:

    PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘wpmem_admin_add_new_user’ not found or invalid function name

    Any ideas on what might be causing this? Thanks.

Viewing 1 replies (of 1 total)
  • Plugin Author Chad Butler

    (@cbutlerjr)

    That function is hooked to the WP action user_new_form. The function is part of the /admin/admin.php file which is only loaded if the user has ‘edit_theme_options’ capability. Administrator and Super Admin roles both have this capability by default, but if a user role editor is being used to remove that capability from a role using the add new user form, then that would cause the warning.

    Technically, the function should probably be moved from admin/admin.php to admin/users.php, in which case the ‘list_users’ capability would be required. This will be evaluated for a future update.

Viewing 1 replies (of 1 total)
  • The topic ‘PHP Warning’ is closed to new replies.