Support » Installing WordPress » PHP version error message on install

  • longjon

    (@longjon)


    Trying to install 3.2.1 and get this:

    “Your server is running PHP version 5.1.6 but WordPress 3.2.1 requires at least 5.2.4.”

    OK so here’s the output from my server:

    # php --version
    PHP 5.3.8 (cli) (built: Nov 11 2011 22:14:52)
    Copyright (c) 1997-2011 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
    # mysql --version
    mysql  Ver 14.12 Distrib 5.0.77, for redhat-linux-gnu (i686) using readline 5.1

    WP doesn’t seem to be picking up correct versions – any ideas?

Viewing 3 replies - 1 through 3 (of 3 total)
  • ChristiNi

    (@christini)

    Hi longjon,

    Just to be sure PHP is set up correctly, I would recommend uploading a phpinfo page up to your hosting account to double check that PHP version:

    View PHP Settings With phpinfo Page

    It looks like you’re doing the automatic update from within the WordPress. If your phpinfo page confirms the correct PHP version, you may want to try updating WordPress manually:

    http://codex.wordpress.org/Updating_WordPress#Manual_Update

    I hope this helps!

    longjon

    (@longjon)

    Hi,

    Thanks for that, phpinfo also reported php version 5.2.10, so I deleted and re-unpacked the tarball and – it just worked!

    All set now!

    Thanks again,

    Jon

    ChristiNi

    (@christini)

    Glad you got this sorted out Jon! If you have time, please mark this post as resolved.

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP version error message on install’ is closed to new replies.