Support » Plugin: Duplicator - WordPress Migration Plugin » PHP version compatibility

  • Resolved theophil_bethel

    (@theophil_bethel)


    Hello team !

    I’m a great fan of your wonderful plugin wich saved my life more than once…

    Could you tell me wich latest version of PHP is Duplicator compatible ?
    I have to upgrade my server and I want to be sure about this.

    PHP Compatibility Checker I used to check it with PHP v7.0 found 11 errors and 8 warnings :

    —————————————————–
    FILE: /home/phildela33/www/reseau-chretien-gironde/wp-content/plugins/duplicator/installer/build/ajax.step2.php
    —————————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    —————————————————————————————————————
    25 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    —————————————————————————————————————

    FILE: /home/…/wp-content/plugins/duplicator/installer/build/ajax.step1.php
    —————————————————————————————————————
    FOUND 7 ERRORS AFFECTING 7 LINES
    —————————————————————————————————————
    55 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    276 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    297 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    298 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    299 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    303 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    380 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    —————————————————————————————————————

    FILE: /home/…/wp-content/plugins/duplicator/views/tools/diagnostics.php
    ————————————————————————————————————
    FOUND 0 ERRORS AND 4 WARNINGS AFFECTING 2 LINES
    ————————————————————————————————————
    249 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    249 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    250 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    250 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    ————————————————————————————

    Many thanks !
    Regards,
    Theophil

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @theophil_bethel,

    Thanks for the feedback! There are a few items on the FAQ that may provide a solution with this issue, this one may get you going.

        – Does Duplicator work with PHP 7?
        – https://snapcreek.com/duplicator/docs/faqs/#faq-about-030-q

    Let me know if any of them help~

    Thread Starter theophil_bethel

    (@theophil_bethel)

    Hi Cory,

    thanks for this flash answer!

    Yes this faq is quite clear, including the way compatibility checker processes code.
    Sounds like a GO to me for Duplicator.
    Upgrading to PHP 7, some real problems remain with other plugins I’m using.

    Please, keep on making our life simpler with your great plugin !
    Best regards from France

    Thread resolved

    Plugin Author Cory Lamle

    (@corylamleorg)

    Excellent! Thanks for the update…

    Cheers~

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP version compatibility’ is closed to new replies.