Support » Plugin: LifterLMS » PHP version

  • Resolved ameliehub

    (@ameliehub)


    Hello,
    I’ve tryed with my hosting company to upgrade my php version to 7.2 in order to upload your plugin. But it gives me an error :
    Warning:
    Use of undefined constant WP_CONTENT_DIR – assumed ‘WP_CONTENT_DIR’ (this will throw an Error in a future version of PHP) in /home1/amelie/public_html/testecommerce.designerslinen.com/wp-includes/load.php on line 141.
    Is there something I can do?
    Thanks for your help

Viewing 1 replies (of 1 total)
  • Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @ameliehub,

    That’s a strange error and I’m sorry that you’re encountering this on your site.

    To my knowledge LifterLMS does not reference this constant WP_CONTENT_DIR anywhere in the codebase.

    A search through our GitHub repository (where all the source code is housed) shows no results for the string: https://github.com/gocodebox/lifterlms/search?q=WP_CONTENT_DIR&unscoped_q=WP_CONTENT_DIR

    This is happening when you try to upload the plugin via the plugins -> add new screen? If it is could you make sure you’re uploading the absolute latest version of LifterLMS? Instead of uploading a zip try searching for LifterLMS on the plugins screen and installing it that way (which will pull the latest version from WordPress.org).

    It is possible that this is coming from another plugin but is being triggered by LifterLMS inadvertently. You could try temporarily disabling other plugins and then installing LifterLMS. If that works you could then reenable the other plugins. I don’t know if that will exactly fix the problem but it *might* bypass the issue.

    Let me know if that helps,

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.