Support » Plugin: Simple Membership » Php version 7+ ??

  • FILE: /home/######/public_html/wp-content/plugins/simple-membership/classes/class.swpm-transfer.php
    ———————————————————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————————————————————————
    22 | WARNING | Method name “SwpmTransfer::__contruct” is discouraged; PHP has reserved all method names with a double underscore prefix for future use.
    ———————————————————————————————————————————————————

    Is this plugin compatible with php 7+ , and are these anything to worry about with an upgrade?

    FILE: /home/#######/public_html/wp-content/plugins/simple-membership/lib/stripe-gateway/lib/StripeObject.php
    ———————————————————————————————————————————————————
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    ———————————————————————————————————————————————————
    268 | WARNING | Method name “StripeObject::__toJSON” is discouraged; PHP has reserved all method names with a double underscore prefix for future use.
    283 | WARNING | Method name “StripeObject::__toArray” is discouraged; PHP has reserved all method names with a double underscore prefix for future use.

    • This topic was modified 2 years, 8 months ago by Condog.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi, thank you reaching out to us and letting us know about the above warnings. I have submitted a message to the developers to investigate further these warning.

    Kind regards

    Plugin Author wp.insider

    (@wpinsider-1)

    Yes the plugin is PHP7 compatible. Warnings are not something that will prevent any functionality from working. There is one warning from one of the files of our plugin which I will fix asap. The couple of other warnings are coming from the Stripe’s library. We use their library for the Stripe gateway. When they release an upgraded version of their library, we will update it in our plugin.

    Thread Starter Condog

    (@condog)

    Thanks for your reply. Does that mean in future updates the double __ will be removed?

    Plugin Author wp.insider

    (@wpinsider-1)

    Yes, we have already removed it from the 2 function names that were in our code.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Php version 7+ ??’ is closed to new replies.