Support » Plugin: Ebook Store » PHP version 7.2 need to update.

  • Resolved hardipparmar

    (@hardipparmar)


    Hello Support team,

    I just want to inform you If your plugin is not compatible with PHP 7.2 version so Kindly, please compatible your plugin with PHP 7.2 version.

    Please check below error log.

    FILE: /nas/content/staging/principlestofo/wp-content/plugins/ebook-store/includes/fpdi/fpdi_pdf_parser.php
    ----------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ----------------------------------------------------------------------------------------------------------
     69 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ----------------------------------------------------------------------------------------------------------
    
    FILE: /nas/content/staging/principlestofo/wp-content/plugins/ebook-store/includes/fpdi/pdf_parser.php
    -----------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    -----------------------------------------------------------------------------------------------------
     101 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    -----------------------------------------------------------------------------------------------------
    
    FILE: /nas/content/staging/principlestofo/wp-content/plugins/ebook-store/includes/fpdi/pdf_context.php
    ------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ------------------------------------------------------------------------------------------------------
     40 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ------------------------------------------------------------------------------------------------------
    
    FILE: /nas/content/staging/principlestofo/wp-content/plugins/ebook-store/includes/fpdi/filters/FilterASCII85_FPDI.php
    ---------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ---------------------------------------------------------------------------------------------------------------------
     26 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ---------------------------------------------------------------------------------------------------------------------
    
    FILE: /nas/content/staging/principlestofo/wp-content/plugins/ebook-store/includes/fpdi/filters/FilterLZW_FPDI.php
    -----------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    -----------------------------------------------------------------------------------------------------------------
     26 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    -----------------------------------------------------------------------------------------------------------------
    
    FILE: /nas/content/staging/principlestofo/wp-content/plugins/ebook-store/includes/fpdi/FPDI_Protection.php
    -------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 4 ERRORS AFFECTING 1 LINE
    -------------------------------------------------------------------------------------------------------------------------------------------------------
     125 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
     125 | ERROR | Function mcrypt_decrypt() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
     125 | ERROR | The constant "MCRYPT_ARCFOUR" is deprecated since PHP 7.1 and removed since PHP 7.2
     125 | ERROR | The constant "MCRYPT_MODE_STREAM" is deprecated since PHP 7.1 and removed since PHP 7.2
    -------------------------------------------------------------------------------------------------------------------------------------------------------
    
    FILE: /nas/content/staging/principlestofo/wp-content/plugins/ebook-store/includes/fpdi/fpdi.php
    -----------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    -----------------------------------------------------------------------------------------------
     466 | WARNING | Function each() is deprecated since PHP 7.2; Use a foreach loop instead
    -----------------------------------------------------------------------------------------------
    
    FILE: /nas/content/staging/principlestofo/wp-content/plugins/ebook-store/fpdi/fpdf.php
    --------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    --------------------------------------------------------------------------------------
     1040 | WARNING | INI directive 'mbstring.func_overload' is deprecated since PHP 7.2
    --------------------------------------------------------------------------------------
    
    FILE: /nas/content/staging/principlestofo/wp-content/plugins/ebook-store/fpdi/FPDI_Protection.php
    -------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 4 ERRORS AFFECTING 1 LINE
    -------------------------------------------------------------------------------------------------------------------------------------------------------
     134 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
     134 | ERROR | Function mcrypt_decrypt() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
     134 | ERROR | The constant "MCRYPT_ARCFOUR" is deprecated since PHP 7.1 and removed since PHP 7.2
     134 | ERROR | The constant "MCRYPT_MODE_STREAM" is deprecated since PHP 7.1 and removed since PHP 7.2
    -------------------------------------------------------------------------------------------------------------------------------------------------------
    
    FILE: /nas/content/staging/principlestofo/wp-content/plugins/ebook-store/fpdi/fpdi.php
    -----------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    -----------------------------------------------------------------------------------------
     562 | WARNING | Function each() is deprecated since PHP 7.2; Use a foreach loop instead
    -----------------------------------------------------------------------------------------

    Thanks,

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author motov.net

    (@motovnet)

    Hello,

    It works on PHP 7.2 also, but yes there are warnings of soon to be deprecated functions.

    They can be ignored at this point though. Of course we will work on making it complatible asap.

    Thanks for reminding us, It goes on top of my list.

    Thanks again!

    Plugin Author motov.net

    (@motovnet)

    I am verifying the compatibility right now to be sure.

    Thanks

    Yes please look into this.

    Also, As per Code formate, There are some errors.

    FILE: /nas/content/staging/principlestofo/wp-content/plugins/ebook-store/includes/fpdi/FPDI_Protection.php
    -------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 4 ERRORS AFFECTING 1 LINE
    -------------------------------------------------------------------------------------------------------------------------------------------------------
     125 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
     125 | ERROR | Function mcrypt_decrypt() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
     125 | ERROR | The constant "MCRYPT_ARCFOUR" is deprecated since PHP 7.1 and removed since PHP 7.2
     125 | ERROR | The constant "MCRYPT_MODE_STREAM" is deprecated since PHP 7.1 and removed since PHP 7.2
    -------------------------------------------------------------------------------------------------------------------------------------------------------
    FILE: /nas/content/staging/principlestofo/wp-content/plugins/ebook-store/fpdi/FPDI_Protection.php
    -------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 4 ERRORS AFFECTING 1 LINE
    -------------------------------------------------------------------------------------------------------------------------------------------------------
     134 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
     134 | ERROR | Function mcrypt_decrypt() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
     134 | ERROR | The constant "MCRYPT_ARCFOUR" is deprecated since PHP 7.1 and removed since PHP 7.2
     134 | ERROR | The constant "MCRYPT_MODE_STREAM" is deprecated since PHP 7.1 and removed since PHP 7.2
    -------------------------------------------------------------------------------------------------------------------------------------------------------
    

    So please look and let us know.

    Thanks,

    hardipparmar

    (@hardipparmar)

    I have updated PHP 7.2 on the staging server and there are affecting those deprecated PHP 7.1 functions.

    Some of the emails are not working and some of the PDF has not been download.

    So can you please check above deprecated PHP functions and Please fix it.

    hardipparmar

    (@hardipparmar)

    When the ebook order placed then ‘encrypted_pdf’ order meta “in_progress” to not change.

    your plugin is used fpdi PDF and this fpdi version is old so as per above-shared script functions is deprecated.

    So Kindly, Please update your fpdi PDF version and your plugins version with PHP 7.2.

    For the testing Please refer this plugin so you can more idea about PHP 7.2
    https://wordpress.org/plugins/php-compatibility-checker/

    [Moderator note: Please, No bumping.

    • This reply was modified 8 months ago by  hardipparmar.
    • This reply was modified 7 months, 3 weeks ago by  Steve Stern.
    Plugin Author motov.net

    (@motovnet)

    I’ll do a complete test in 7.2 again and issue an update where needed.

    Thanks for the valuable feedback on this.

    Kind regards,
    Deian Motov

    Plugin Author motov.net

    (@motovnet)

    Hello,

    I can confirm the latest version seem to work with PHP 7.2, I will try to resolve any warnings in next updates. We will also update the PDF framework.

    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘PHP version 7.2 need to update.’ is closed to new replies.