Support » Plugin: Remote Media Libraries » PHP Version

  • Hello!

    I was hoping to test this plugin on my site to add YouTube videos to our media library, but I am unable to even run it due to our PHP version being 5.3.1. Is there a reason why 5.3.3 is necessary for this plugin? Running WordPress 4.3 only requires 5.2.4 or greater. I can’t imagine that there would be a huge difference between 5.3.1 and 5.3.3. Just curious if there’s any way to try this running my version as I would like to test it to see if it will solve our issue.

    Thanks!

    https://wordpress.org/plugins/remote-medias-lite/

Viewing 1 replies (of 1 total)
  • Plugin Author Louis-Michel Raynauld

    (@loumray)

    Hi Alexia,

    The plugin uses a code library for connecting to media services that needs 5.3.3. As you can see for yourself here (http://php.net/ChangeLog-5.php#5.3.3), there is in fact quite a difference between 5.3.1 and 5.3.3…

    It is true wordpress support old php version up to 5.2.4. However, PHP itself does not support 5.4 and older (see http://php.net/supported-versions.php)

    Using deprecated PHP versions is rather unsecure and not recommended even if wordpress still support these versions.

    As a side note, I have to say that I am looking at the possibility to drop support of PHP 5.3 in the near future;

    So i’m sorry, it cannot run on your current PHP version. I invite you to give a try to PHP 5.6, it is worth the time. Faster and safer, you won’t regret it!

    Cheers,

Viewing 1 replies (of 1 total)
  • The topic ‘PHP Version’ is closed to new replies.