Support » Alpha/Beta/RC » PHP Version

  • Resolved summerchilde

    (@summerchilde)


    I’m curious to know if WordPress 3.2 will work at all with PHP 5.2.17. I know from the latest WordPress.org blog post that 3.2 will require PHP 5.2.4 and MySQL 5.0.. My MySQL is the correct version but the PHP is not.

    Waiting to hear back from my hosting provider to see if they plan to upgrade. This will suck big time if not.

Viewing 15 replies - 1 through 15 (of 17 total)
  • esmi

    (@esmi)

    Forum Moderator

    It will run just fine. I’m using 5.3.3 without any problems.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    WordPress minimum requirements are PHP 5.2.4. You exceed them. You should be fine.

    Thanks.
    The version numbering is confusing. I thought what I had was below what was needed.

    Ops…on my test domain site the Php version is 5.2.0 🙁
    The Php choice setup is from version 4 to version 5…
    The normal site has 5.2.17 and 5.3.xx as a choice.
    I guess i’ll have to wait to test wp32………

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    You can use 5.3

    If you can upgrade 5.2.0 to at LEAST 5.2.17 (she says, knowing there’s a security hole in .16) it would be good 🙂

    On my testing domain I have no choice, 4.x.x or 5.2.0…
    the other site is ok, but never mess up a working site 🙂

    i’ll wait a week to see if the hosting provider will get the news from wordpress users…

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    I would talk to your host on the test domain. They may have options 🙂

    Talked to ISP, they will update PHP in 1 or 2 months.
    Just for curiosity why was chosen PHP v5.2.4?
    Some host have just switched from version 4….

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    PHP 5 came out in 2004.

    PHP 4 was last supported by PHP in 2008.

    PHP 5.2 is no longer supported by PHP.

    Since 2008, the GoPHP5 initiative has been pushing people to get off PHP 4.

    In other related news? WordPress doesn’t support IE 6 anymore either.

    In 2004?
    Ok, it’s time to retire PHP 4….
    Regarding IE6 for the dashboard no need to support it but for the user output better not cut it out completely yet…..

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    User output is per-theme anyway (but the default themes don’t support it).

    Anybody knows if the php version test is done by the automatic installer or is it also in the running code?
    My host will update PHP probably only after the first dozen complains after the formal release of WP32…..:-(

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    The test is probably just the installer, but as some of the code that supports PHP 4 is being dropped, you’ll see it there too.

    You could install WP 3.2-beta1 on your server to see what’s gonna barf.

    Well I have php 5.2.0, i’m just missing a very minus point release.
    I’ll try a manual update………

    No way. Manual install failed:
    Your server is running PHP version 5.2.0-8+etch15 but WordPress 3.2-beta2 requires at least 5.2.4.

    Any chance to have a more relaxed PHP version check, like “at least 5.2.0”?

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘PHP Version’ is closed to new replies.