WordPress.org

Forums

[resolved] PHP Version (18 posts)

  1. summerchilde
    Member
    Posted 3 years ago #

    I'm curious to know if WordPress 3.2 will work at all with PHP 5.2.17. I know from the latest WordPress.org blog post that 3.2 will require PHP 5.2.4 and MySQL 5.0.. My MySQL is the correct version but the PHP is not.

    Waiting to hear back from my hosting provider to see if they plan to upgrade. This will suck big time if not.

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    It will run just fine. I'm using 5.3.3 without any problems.

  3. WordPress minimum requirements are PHP 5.2.4. You exceed them. You should be fine.

  4. summerchilde
    Member
    Posted 3 years ago #

    Thanks.
    The version numbering is confusing. I thought what I had was below what was needed.

  5. maurizio04
    Member
    Posted 3 years ago #

    Ops...on my test domain site the Php version is 5.2.0 :-(
    The Php choice setup is from version 4 to version 5...
    The normal site has 5.2.17 and 5.3.xx as a choice.
    I guess i'll have to wait to test wp32.........

  6. You can use 5.3

    If you can upgrade 5.2.0 to at LEAST 5.2.17 (she says, knowing there's a security hole in .16) it would be good :)

  7. maurizio04
    Member
    Posted 3 years ago #

    On my testing domain I have no choice, 4.x.x or 5.2.0...
    the other site is ok, but never mess up a working site :-)

    i'll wait a week to see if the hosting provider will get the news from wordpress users...

  8. I would talk to your host on the test domain. They may have options :)

  9. maurizio04
    Member
    Posted 3 years ago #

    Talked to ISP, they will update PHP in 1 or 2 months.
    Just for curiosity why was chosen PHP v5.2.4?
    Some host have just switched from version 4....

  10. PHP 5 came out in 2004.

    PHP 4 was last supported by PHP in 2008.

    PHP 5.2 is no longer supported by PHP.

    Since 2008, the GoPHP5 initiative has been pushing people to get off PHP 4.

    In other related news? WordPress doesn't support IE 6 anymore either.

  11. maurizio04
    Member
    Posted 3 years ago #

    In 2004?
    Ok, it's time to retire PHP 4....
    Regarding IE6 for the dashboard no need to support it but for the user output better not cut it out completely yet.....

  12. User output is per-theme anyway (but the default themes don't support it).

  13. maurizio04
    Member
    Posted 3 years ago #

    Anybody knows if the php version test is done by the automatic installer or is it also in the running code?
    My host will update PHP probably only after the first dozen complains after the formal release of WP32.....:-(

  14. The test is probably just the installer, but as some of the code that supports PHP 4 is being dropped, you'll see it there too.

    You could install WP 3.2-beta1 on your server to see what's gonna barf.

  15. maurizio04
    Member
    Posted 3 years ago #

    Well I have php 5.2.0, i'm just missing a very minus point release.
    I'll try a manual update.........

  16. maurizio04
    Member
    Posted 3 years ago #

    No way. Manual install failed:
    Your server is running PHP version 5.2.0-8+etch15 but WordPress 3.2-beta2 requires at least 5.2.4.

    Any chance to have a more relaxed PHP version check, like "at least 5.2.0"?

  17. maurizio04
    Member
    Posted 3 years ago #

    If I change PHP to version 4 the system crash instead of catching the error:

    Parse error: syntax error, unexpected T_VARIABLE in /home/mhd-01/www.pcwi.it/htdocs/wordpress/wp-includes/load.php on line 566

    Do I have to create a ticket?

  18. They make calls to things that don't exist in 5.2.0 I believe so ... no :(

    Open a ticket to your host, for sure.

Topic Closed

This topic has been closed to new replies.

About this Topic