Support » Fixing WordPress » Php upgrade

  • Resolved skolaprachen

    (@skolaprachen)


    I tried to upgrade my PHP version from 7.0 to 7.4, I followed all the instructiones, made the backup, deactivated all the plugins… Still there is a fatal error…

    Fatal error: Uncaught Error: Call to undefined function wp_register_tinymce_scripts() in /web/htdocs3/skolaprachencz/home/www/wp-includes/script-loader.php:633 Stack trace: #0 /web/htdocs3/skolaprachencz/home/www/wp-includes/class-wp-hook.php(310): wp_default_packages(Object(WP_Scripts)) #1 /web/htdocs3/skolaprachencz/home/www/wp-includes/class-wp-hook.php(334): WP_Hook->apply_filters(NULL, Array) #2 /web/htdocs3/skolaprachencz/home/www/wp-includes/plugin.php(565): WP_Hook->do_action(Array) #3 /web/htdocs3/skolaprachencz/home/www/wp-includes/class-wp-scripts.php(185): do_action_ref_array(‘wp_default_scri…’, Array) #4 /web/htdocs3/skolaprachencz/home/www/wp-includes/class-wp-scripts.php(160): WP_Scripts->init() #5 /web/htdocs3/skolaprachencz/home/www/wp-includes/functions.wp-scripts.php(24): WP_Scripts->__construct() #6 /web/htdocs3/skolaprachencz/home/www/wp-includes/functions.wp-scripts.php(187): wp_scripts() #7 /web/htdocs3/skolaprachencz/home/www/wp-includes/blocks.php(173): wp_register_script(‘wp-block-file-v…’, ‘ in /web/htdocs3/skolaprachencz/home/www/wp-includes/script-loader.php on line 633

    What can I do with this??? I have installed the Filezilla.

    Thanks in advance for your advice.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi @skolaprachen

    Looks like you’ll have to update WordPress as well.
    You can see how to manually update WordPress here.

    Best regards
    Aris Kuckovic

    Thread Starter skolaprachen

    (@skolaprachen)

    Thanks for your reply, I did what you recomanded – even though I already apdated word press before changing PhP versin.

    It is the same … the Fatal error note did not change :(.

    May it be something wrong with the file script- loader?

    function wp_default_packages( $scripts ) {
    wp_default_packages_vendor( $scripts );
    wp_register_development_scripts( $scripts );
    wp_register_tinymce_scripts( $scripts );
    wp_default_packages_scripts( $scripts );

    if ( did_action( 'init' ) ) {
        wp_default_packages_inline_scripts( $scripts );
    }

    }

    This is what is described as a fatall error – is there anything I can change about it?

    @skolaprachen

    Hmm – I would never change any core-files in WordPress.
    Whenever I encountered an error in the “wp_admin” og “wp_includes” folder, it was solved by deleting the 2 folders from the FTP server, and reuploading them.

    Bonjour, je suis dans la même situation que vous @skolaprachen.

    Actuellement, j’essaie de passer de PHP 7.4 à PHP 8.0.

    Dans mon cas, j’ai bien la dernière version WP, mes plugins sont à jour et j’ai désactivé le plugin non compatible avec la version PHP 8.

    Pour vérifier la compatibilité de vos plugins à la version PHP en question, vous pouvez installer PHP compatibility Checker.

    Le problème vient de mon thème qui n’est pas mis à jour par l’éditeur depuis 2022. Du coup, j’ai envoyé une demande à l’assistance technique de mon thème en question ; Son retour : il va vérifier la compatibilité du thème avec la dernière version de WP et une mise à jour sortira prochainement. À suivre…

    Thread Starter skolaprachen

    (@skolaprachen)

    Merci pour votre message, en fait, j’ai finalement réussi à résoudre le problème – l’erreur venait en réalité du fait que je n’avais pas mis à jour tous les thèmes. J’ai dû revenir à la version PHP 7 et tout mettre à jour directement dans WordPress. Et cela, même si j’avais vérifié que tout était compatible avec PHP à l’aide de PHP Compatibility Checker. Bonne chance !

    BTW – I canť speak french– fortunately AI made a translation of my answer – hope it is undersatndeble. 🙂

    Thanks for your french feedback 🙂 AI, a good idea for the translation!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.