Support » Fixing WordPress » PHP update breaks wp-admin

  • Resolved csanyk

    (@csanyk)


    I am hosted by 1and1, and they recently notified me that my PHP version (5.2) is no longer supported, and advised me to update to PHP 5.5.

    I did so, and my wordpress application is still able to serve page requests to visitors, but if I try to browse to my wp-admin pages, I get a 500 Internal Server error:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@[my domain].com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I contacted 1and1 support, they tried to fix it on their end. I don’t know what they did, but it did not work. They then advised that I could try changing my PHP version to 5.4. I tried this, and it still did not fix the problem.

    I googled for info on wordpress problems with upgrading PHP, and came upon this thread:

    https://wordpress.org/support/topic/just-upgraded-to-php-54-and-site-doesnt-work

    One of the replies suggested re-entering my mySQL password in 1and1 admin. I tried this, but it still hasn’t fixed the problem.

    If I revert back down to PHP 5.2, I can get back into my wp-admin pages again. But I can’t stay on PHP 5.2 without paying 1and1 for extended support.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hey,

    The e-mail we send did missed some information. I assumed that your installation is a free mode click & build installation. The problem is your php.ini file. This has incorrect information in it when it was installed before januari this year. If you send your customer id and domain to [email deleted] I could fix it for you.

    Best,
    Marko Heijnen
    1&1 WordPress specialist.

    Marko, thanks so much for getting involved. You were the most helpful out of anyone at 1and1 who I dealt with during the last two days. Without your attention, I would not have been able to resolve the problems with the wp installation, or get php updated.

    No problem. This kind of issues are not easy to solve but I will do my best to let all our customer care people know about this issue and it’s solution.

    I have the same issue as csanyk, exactly the same…

    So, should I have to downgrade php from 5.5 to 5.4?

    What modifications should I have to do into php.ini?

    best,
    Raphael Franchi

    raphael1982, this is what Marko emailed me privately about php.ini:

    Till January 22th the php.ini file we created with Click&build had to many settings in it. Two of them got deprecated in PHP 5.3 and removed in PHP 5.4 and because of that the your site crashes. This two lines are:

    browscap = /usr/local/lib/browscap.ini
    magic_quotes_gpc = on

    We now completely cleared the file and for WordPress we only have: safe_mode = off. For our safe mode installation we could fix it because we manage the installation but for free mode installation it’s more tricky because we are not allowed to change files without the customers approval.

    Be sure to make a backup copy of php.ini before you modify it, just in case. Hope this helps.

    Thanks a lot.

    Should I have to rewrite all php.ini or only the one contained into the root directory?

    best,
    Raphael

    Hey Raphael,

    I saw your e-mail. You can use this tool I wrote to fix all php.ini files:
    https://gist.github.com/markoheijnen/1fb8aef0b3069d813ec7

    Best,
    Marko

    Thanks a lot, where should I have to copy it? and how should I have to run it?

    best,
    Raphael

    Hi,

    The same thing has been happening to my WordPress sites hosted through 1and1 since last Thursday 11-6-14. Nothing on my end has changed. Did 1and1 change something?

    Thanks,
    Rob

    Hey Rob,

    We don’t change someones PHP because that would break quite a few sites. The best/fastest solution is to check if it’s your php.ini file by just renaming it to something like php.ini-old. You could also try calling our support.

    We didn’t change anything as far as I know in the last week.

    Best,
    Marko

    Also we fixed the issues we caused when using Click&Build now.

    Running the tool that Marko mentioned fixed my issue where I couldn’t update to php 5.5 without getting an error. Thank you so much!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘PHP update breaks wp-admin’ is closed to new replies.