• Resolved ten12design

    (@ten12design)



    Seeing I am using this plugin and I am updating my sites to the latest PHP version I noticed that when using this plugin it causes an error. I had to go back to PHP 5.6 so the errors would go away.

    Will you be updating this plugin to meet the newest version of PHP?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Ewout

    (@pomegranate)

    Hi! This plugin is tested up to and compatible with PHP 7.1. We are not aware of any issues with 7.2, but since we also use some external libraries, 7.1 is recommended. Which PHP version did you switch to and what was the error you got?

    Any information you can provide about your configuration would be more than welcome!
    Ewout

    So when we have it set to 7.0 and when we go into the orders and click the PDF button to view we get this error.

    This is the error we are getting. Warning: array_merge(): Argument #2 is not an array in /home/mmesrobian/public_html/staging2/wp-includes/load.php on line 63

    It goes away when we put it back to PHP 5.6

    Same for the shipping tickets

    Plugin Author Ewout

    (@pomegranate)

    Hi! Thanks for sharing the error!
    Looks like an issue with your server configuration, as this a core WP function:
    https://github.com/WordPress/WordPress/blob/4.9.4/wp-includes/load.php#L63

    It is possible that this warning (which in itself doesn’t do much harm) shows up with PDF invoices enabled when you have enabled the setting “Debug Output” in the PDF invoice > Status settings. That option will show all PHP errors.

    You can either disable debug output and/or WP_DEBUG (which will hide but not fix the error), or contact your host and tell them the $_SERVER variable needs to be setup correctly.

    Hope that helps!
    Ewout

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP update’ is closed to new replies.