Support » Plugin: Slash Admin » PHP Support in Slash Admin v3.7

  • Resolved ChadCloman

    (@chadcloman)


    EXECUTIVE SUMMARY
    ——————

    The latest Slash Admin update (v3.7) now requires PHP 7 or higher, but doesn’t enforce that restriction.

    Please modify the plugin’s readme.txt file to specify the minimum PHP requirements.

    Instructions here: https://make.wordpress.org/plugins/2017/08/29/minimum-php-version-requirement/

    DETAILS
    ——-

    Due to legacy software that we are actively working to replace, we have to run our WordPress site on PHP 5.6.40.

    In Slash Admin 3.7, line 13 of slashadmin.php (the ‘use’ statement) requires PHP 7+. It crashes our PHP 5.6.40 website when activated.

    From the PHP error log: “PHP Parse error: syntax error, unexpected ‘{‘, expecting identifier (T_STRING) in /<path>/wp-content/plugins/slash-admin/slashadmin.php on line 13”

    If the minimum PHP version requirement had been specified, we wouldn’t have been allowed to install this update.

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP Support in Slash Admin v3.7’ is closed to new replies.