Support » Plugin: FeedWordPress » PHP Strict Standards errors

  • I’m seeing too many errors like the following, please fix this, I’m using the php 5.4.15

    [23-May-2013 22:19:21 UTC] PHP Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method FeedWordPress::admin_api() should not be called statically in /public_html/wp-includes/plugin.php on line 406

    [23-May-2013 22:19:21 UTC] PHP Strict Standards: Non-static method FeedWordPressSettingsUI::is_admin() should not be called statically, assuming $this from incompatible context in /public_html/wp-content/plugins/feedwordpress/feedwordpress.php on line 1246

    [23-May-2013 22:19:21 UTC] PHP Strict Standards: Non-static method FeedWordPress::affirmative() should not be called statically, assuming $this from incompatible context in /public_html/wp-content/plugins/feedwordpress/syndicatedlink.class.php on line 510

    [23-May-2013 22:19:21 UTC] PHP Strict Standards: Non-static method FeedWordPress::munge_permalinks() should not be called statically in /public_html/wp-content/plugins/feedwordpress/feedwordpress.php on line 599

    3-May-2013 22:19:21 UTC] PHP Strict Standards: Non-static method FeedWordPress::munge_permalinks() should not be called statically in /public_html/wp-content/plugins/feedwordpress/feedwordpress.php on line 577

    [23-May-2013 22:19:21 UTC] PHP Strict Standards: Non-static method FeedWordPress::diagnostic_on() should not be called statically in /public_html/wp-content/plugins/feedwordpress/feedwordpress.php on line 293

    http://wordpress.org/extend/plugins/feedwordpress/

Viewing 1 replies (of 1 total)
  • Please fix this! “Non-static method FeedWordPress::diagnostic_on() should not be called statically”

    I’m getting thousands of errors in my loggs because of this and I am not willing to disable strict alerts just because of this error.

Viewing 1 replies (of 1 total)
  • The topic ‘PHP Strict Standards errors’ is closed to new replies.