Support » Plugin: Twitter Tools » PHP Strict Standards errors

  • With debug and debug log enabled, I’m seeing the following errors ONLY when the Twitter Tools plugin is enabled. I don’t believe I’ve seen them before this, but it’s possible they pre-date WP 4.1.

    call_user_func_array() expects parameter 1 to be a valid callback method AKTT::admin_menu() should not be called statically in /<redacted-path-to-wordpress-install>/wp-includes/plugin.php on line 496

    I’m seeing other entries for other methods (with different line numbers mentioned). The other methods that appear are:

    AKTT::admin_controller() - line 496
    AKTT::admin_enqueue_scripts() - line 496
    AKTT::plugin_action_links() - line 213
    AKTT::controller() - line 571

    PHP version in use: 5.5.9-1ubuntu4.5

    https://wordpress.org/plugins/twitter-tools/

  • The topic ‘PHP Strict Standards errors’ is closed to new replies.