Support » Plugins » PHP Strict Errors

  • Resolved coolphoenix

    (@coolphoenix)


    In the new php version 5.4.0, E_STRICT errors/warnings are activated by default. The plugin has some E_STRICT warnings, so they should be finally fixed. Some example errors:

    Strict standards: Accessing static property ckeditor_wordpress::$plugin_path as non static in /wp-content/plugins/ckeditor-for-wordpress/ckeditor_class.php on line 24
    
    Strict standards: Accessing static property ckeditor_wordpress::$plugin_path as non static in /wp-content/plugins/ckeditor-for-wordpress/ckeditor_class.php on line 32
    
    Strict standards: Accessing static property ckeditor_wordpress::$default_options as non static in /wp-content/plugins/ckeditor-for-wordpress/ckeditor_class.php on line 41

    You should activate E_STRICT and check for these errors to fix them.

Viewing 5 replies - 1 through 5 (of 5 total)
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘PHP Strict Errors’ is closed to new replies.