Support » Fixing WordPress » PHP source downloads instead of displaying (sometimes)

  • I’ve been noticing this for a couple of months now, but it’s starting to get really annoying. After a few pokes around the support forums, I haven’t seen anything similar, so am assuming it’s something quirky in my installation.

    Occasionally, pages (not Pages) within my WP blog trigger a download in browsers, rather than displaying content. This happens most often when posting a new entry (click “Publish”, wait a few seconds, and you’ll be presented with at “What should Firefox do with this file?” save dialog.

    It seems to be happening more often, but frustratingly it doesn’t happen consistently. It can (sometimes) happen in various parts of my blog, whether it’s posting comments, publishing posts via the admin interface, moderating comments via Spam Karma 2, or even just opening the Write Post screen.

    I’m stumped – if it’s an Apache config issue, no PHP should execute – but the same php file will render on one request, and download on another. If it’s a browser issue, it should be consistent. I’ve tried turning off modules, changing themes (but it happens in the admin interface, too…)

    I took a screenshot of one of the dialogs.

    I’d appreciate any ideas anyone might have.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Lots of factors that can cause this. Some random thoughts:

    Look hard at your plugins. If any of them are doing major work, try disabling them. I’ve seen this happen when PHP isn’t configured with a high enough max mem setting (default is often around 8MB. Upping that to 12 or 20 might be enough to fix the problem). If this is the issue, you’ll see it your web server error logs.

    Time outs are another way to cause this to happen. For instance, do you still have the default of configured for your ping service? (Options -> Writing, scroll down to “Update Services”). If so, try removing it. If nothing else, that will speed you up when making a post.

    More often than not, this comes from the file (or the server) from not properly sending the right HTTP header and instead of processing the file, the server thinks it needs to send it to the client. You may want to contact your web host and see if there is something they can diagnose from their side of things.

    In the meantime, Handy has the right idea, try disabling some if not all of your plugins and see if it still happens. It also wouldn’t surprise me if there’s something in common those posts have (a word, or some kind of misplaced code or something) in common even though you may not think about it at the time.


    I run Wampserver locally, and there are days when I start it up, try to access a PHP page, and have this happen. Sometimes restarting the services (a few times…) will kick it back into working properly, sometimes I need to reboot. I’ve yet to figure out what would cause this. Just thought I’d add another datapoint. 😉


    Hi, i do have exactly the same problem as dnorman wrote (sometimes php code is not executed, instead send for downloading).
    I am using a Suse configuration with Apache 2.0.53 and php 5.0.3 and some virtual hosts. My memory limit is at 32MB and it still happens sometimes. It now happens more often than in earlier times. I am really getting confused about it, because i have no idea how to reproduce it. I even wasnt able to find something in the log-files
    Thanking you in advance for giving me any hint

    Mark (podz)


    Support Maven

    I am also seeing this sometimes.
    It has happened on my blog (over which I have some control) and also on a blog when commenting (no control there).
    I’ve added no new Firefox extensions, I’ve not fiddled with any browser settings.
    If I just refresh the page the error goes and like above there is no consistency.


    Someone mentioned that the fasterfox extension can cause this behaviour.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘PHP source downloads instead of displaying (sometimes)’ is closed to new replies.