Support » Plugin: Fast Secure Contact Form » PHP safe_mode turned on

  • Resolved Chijo

    (@chijotakeda)


    We have been experiencing a situation where the form is not sending out messages but it’s off and on. I did notice the warning in RED: “Warning: Your web host has PHP safe_mode turned on.”

    However, I’ve confirmed that safe_mode is in fact OFF. I’ve run phpinfo and it says that it is OFF.

    Could it be possible that the plugin is erroneously reporting that safe_mode is ON?

    http://wordpress.org/extend/plugins/si-contact-form/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Mike Challis

    (@mikechallis)

    Could it be possible that the plugin is erroneously reporting that safe_mode is ON?

    yes it is possible.
    What is your version of PHP and is it Luinux or Windows server?

    Would you mind testing something?

    edit plugins/si-contact-form/admin/si-contact-form-admin.php line 980
    change

    $safe_mode_is_on = ((boolean)@ini_get('safe_mode') === false) ? 0 : 1;
    if($safe_mode_is_on){

    to:
    if ( ((bool)@ini_get("safe_mode") === true ) ) {

    Did that make the message go away?

    Chijo

    (@chijotakeda)

    PHP 5.3.22
    Yes, Linux
    Apache 2.2.23

    I made the revision on line 980 but the message is still there.
    Warning: Your web host has PHP safe_mode turned on. PHP safe_mode can cause problems like sending mail failures and file permission errors.
    Contact your web host for support.

    Plugin Author Mike Challis

    (@mikechallis)

    are you also having a session_start error? try fixing that first, then this may go away. Let me know if after fixing the sessions the problem remains.

    Chijo

    (@chijotakeda)

    The session start error has been fixed and the warning message went away.

    Thanks so much for your help!

    Hi Mike,

    we have the same problem with a client web site, which is on a windows server.
    No errors – when mail is sent.
    Test mail sends properly.
    Hosting confirmed that safe_mode is off.
    After modifying the file as described above the red message is still there. Weird, never saw this before and it seems it does not really have an impact.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘PHP safe_mode turned on’ is closed to new replies.