Support » Plugin: Custom Content Shortcode » PHP Parse error on ccs-comments.php

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Eliot Akira

    (@miyarakira)

    Oh, thank you for telling me! I believe I corrected it – please download the latest update.

    Strange, on my setup I was not getting any errors. Perhaps it’s related to PHP version. I was making an empty array using [], but I changed it to use array().

    Please let me know if that solves it.

    brandon.hcreativemedia

    (@brandonhcreativemediacom)

    Works, thank you!

    Plugin Author Eliot Akira

    (@miyarakira)

    Great, sorry about the hiccup, and thanks for letting me know.

    Hi,

    I just got a similar problem on line 61 of that same file:
    $atts = [‘content’]; // Default field

    The server error_log was showing a php parse error like “unexpercted ‘[‘”.

    The server’s php version is 5.4.24.

    I hope this helps.

    Thanks!

    Plugin Author Eliot Akira

    (@miyarakira)

    Thanks, I just fixed this. Interesting, so you have PHP >=5.4 – I didn’t realize it didn’t support array literals. Yes..I’ve been working a lot with JavaScript these days, and some of the coding habits are creeping into my PHP. I really need to set up a test server to ensure compatibility. I appreciate the feedback!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘PHP Parse error on ccs-comments.php’ is closed to new replies.