Support » Plugin: Portfolio Slideshow » PHP Parse error

Viewing 15 replies - 1 through 15 (of 20 total)
  • Hi,
    I’m getting the same error after Worpdress upgraded to 4.2.4;

    “Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected ‘[‘ in /home/myusername/public_html/wp-content/plugins/portfolio-slideshow/lib/Plugin.php on line 57″

    The site is here: http://richardjamesupholstery.com/coach-trimming/rolls-royce-silver-ghost-1925/

    Any help would be much appreciated, thank you in advance.

    Same problem here.
    I had to go back to the old version.

    Hi dwheeler,
    do you mean the old version of the plugin or WP?!
    I don’t have an older version to try unfortunately.

    HOwever, it looks like there are quite a lot of posts on here about this problem, so hopefully there will be a fix soon…

    I had the same issue when I upgraded to the new version of the plugin. I’m using WP 4.2.4. The site disappeared. No admin. No site. Fortunately had an old version of the plugin in a test environment. I copied that to the live site and it’s fine now.

    Same behavior on my WP website. The problem is that my PHP 5.3.10 version doesn’t parses the ‘[‘ array statement (php -l ./lib/Plugin.php)

    Validation on another server with PHP 5.5 shows no errors.

    Renaming the portfolio plugin directory and restarting webserver gets the website online again. No slides shows of cause as the plugin is not loaded.

    The back port to PHP 5.3 is not working, at least for my version which comes with Ubuntu 12.04.5 LTS. This version is out there a lot I guess, so fixing the plugin makes sense in stead of upgrading PHP by hand…

    Regards,
    Ferry

    Same issue here – I’ve downloaded v1.5.1 from the Developers tab:

    https://wordpress.org/plugins/portfolio-slideshow/developers/

    1) Deleted v1.9.9
    2) Uploaded v1.5.1
    3) Activated v1.5.1

    Site now working again.

    Thanks andoverit,
    that worked a treat!

    Tim Smith

    (@creativeinfusion)

    The fault is actually that contrary to the plugin description it now needs PHP 5.4 to work.

    The code is using the new short form array syntaxt that is only supported in PHP >= 5.4

    Thanks Tim and a pleasure Smoo – glad it helped 🙂

    PHP Parse error: syntax error, unexpected ‘[‘ in wp-content/plugins/portfolio-slideshow/lib/Plugin.php on line 57

    Not Working also in Version 1.10

    Had the same error, went to the development tab on the wordpress plugin site and installed several versions back and it worked fine. Now I have to tell the client not to update their plugin for what we don’t know how long.

    thanks for the link to previous version list.

    Yes, thanks for the link and advice andoverit! You saved my site!

    Thank you so much andoverit! I’ve had this issue on several sites!

    Can anyone help please?

    I have just tried to do an update of my plugins the new version of WordPress.

    I am getting the same error as mentioned above and I can no longer log into the wordpress admin as it no longer recognises me. Why can’t I get back into the admin and can I get my site back the way it was before the upgrade??

    Please be gentle with me as I am not a website expert!!

    Here is how my site is looking now: –

    http://www.evergreenframedart.co.uk/

    Thank you

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘PHP Parse error’ is closed to new replies.