• Resolved silvadiego705

    (@silvadiego705)


    With the WP_DEBUG enabled there are several PHP notices created by the gallery:

    Notice: WC_Product::get_gallery_attachment_ids is deprecated since version 3.0! Use WC_Product::get_gallery_image_ids instead. in /var/www/site/wp-includes/functions.php on line 3837

    Notice: WC_Product::get_gallery_attachment_ids is deprecated since version 3.0! Use WC_Product::get_gallery_image_ids instead. in /var/www/site/wp-includes/functions.php on line 3837

    These notices show up because WooCommerce 3 deprecated the indicated functions and the “Twist – Woocommerce Product Gallery Slider Free” plugin still uses them.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Niloy

    (@im_niloy)

    Did you check by enabling the wc version 3.0+ option from wpgs settings?
    There has a toggle button for this problem. please kindly check and let me know

    Yes, it does work with the “WooCommerce 3.0+ Fix” enabled”.

    Is there any reason why the fix isn’t applied automatically when WooCommerce 3.0+ is enabled? You can check the WooCommerce version with the following code:

    if ( class_exists('woocommerce') && version_compare( WC_VERSION, '3.0', '>') ) {
        \\ enqueue prettyPhoto CSS and JS
    }

    Another question, unrelated to the topic:

    The public/js/woocommerce-product-gallery-slider-public.js file is enqueued even if the code inside does absolutely nothing. Am I missing something?

    Plugin Author Niloy

    (@im_niloy)

    The version_compare option is enabled on pro version. I will add it also in next release for this free plugin 🙂
    public/js/woocommerce-product-gallery-slider-public.js may have some codes in an earlier version but in present version may not have any code. btw, I will check this too.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP notices’ is closed to new replies.