Support » Plugin: Awesome Support - WordPress HelpDesk & Support Plugin » PHP Notice: wp_script_is Scripts and styles should not be registered…

  • Awesome Support 3.3.1

    Hey there, hope you’re well..

    If Awesome Support is active, the following message appear in our debug log:

    PHP Notice: wp_script_is was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks.

    It just happens on a page-load in the wp-admin section and just if Awesome Support is active.
    I searched in your files for the error-source, but I do not found it.

    Any idea why this happens?

    Thank you and best regards.

    https://wordpress.org/plugins/awesome-support/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Julien Liabeuf

    (@julien731)

    Hi IndikatorDesign,

    Have you been able to confirm that the notice is triggered by Awesome Support?

    Hi Julien,

    it just appear, if Awesome Support is active. After deactivating AS, there are no more messages in the debug log..

    Thank you and best regards.

    Plugin Author Julien Liabeuf

    (@julien731)

    Ok. I will run some tests then and try to catch this notice.

    Thanks a lot..

    Please note, that it was written to the debug.log inside the content-folder with this setup inside wp-config:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    if ( WP_DEBUG )
    {
    	// Save Queries inside database and that array can be displayed to help analyze
    	define('SAVEQUERIES', true);
    
    	// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    	define('SCRIPT_DEBUG', true);
    
    	// debug.log to wp-content
    	define( 'WP_DEBUG_LOG', true );
    	define( 'WP_DEBUG_DISPLAY', false );
    	@ini_set( 'display_errors', 0 );
    	//@ini_set('log_errors','On'); // enable or disable php error logging (use 'On' or 'Off')
    	//@ini_set('error_log','/absolute/path/to/one/folder/above/the/root/logs/errors.log');
    }

    Hello Julien,

    was it possible for you to understand the paled? It provides for a quite big portion of information in the Debug.log what makes debugging quite blindly.

    Thank you and best regards.

    Hello Julien,

    I opened this thread 5 weeks ago. It is important for us to get a solution for the problem, cause we’re wanna start with our shop and for this we need a good support solution. If AS is active it give us the described notices, but it seems that something is also in conflict with the media library.

    We’re really interested into some of your extensions ( Custom Status, E-Mail Support, FAQ, Canned Responses ). But before we purchase them, we wanna be sure that AS works fine for us.

    Is it possible for us to get support from you or should we better take a look for another solution?

    Thank you and best regatrds

    Plugin Contributor elindydotcom

    (@elindydotcom)

    Hi:

    Unfortunately, so far we haven’t been able to reproduce this issue and no one else has reported it. It could be something unique to your environment. Is it preventing something from functioning properly or is it just a notice?

    Hello elindydotcom and thanks for your response.

    There was a problem with the media library. On image-upload the images wasn’t shown in the default view. It was needed to change the view into the list view to see newly uploaded images. It seems that your new update from today has been fixed this issue..

    Our other issue with the notice: PHP Notice: wp_script_is was called incorrectly – still exists. But it seems that this message will just generated, if AS is enabled together with Affiliate Enterprise. This message just appear if both plugins are active (TwentySixteen, AS, AE – nothing else). Nothing happens, if just one of them is enabled..

    Any idea how this can be fixed?

    Thank you and best regards.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘PHP Notice: wp_script_is Scripts and styles should not be registered…’ is closed to new replies.