Support » Plugin: WP Super Cache » PHP Notice: Undefined index: HTTP_HOST from wp cli

  • Resolved Alexey

    (@asel)


    When running some comand from wp cli (http://wp-cli.org)

    wp plugin list for example

    You get this:
    PHP Notice: Undefined index: HTTP_HOST in wp-content/plugins/wp-super-cache/wp-cache-base.php on line 4

    To fix it wrap that line with

    if (php_sapi_name() != 'cli') {
    }

    Fix in next release please

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Donncha Ó Caoimh

    (@donncha)

    Thanks, I wrapped it in an isset() and disabled caching too because that value is used in the cache key as it would never be used by a web visitor.

    Hello, I just encountered this issue as well and I’m glad to see it’s being addressed. Can you give us any idea when the plugin will be updated with this fix?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP Notice: Undefined index: HTTP_HOST from wp cli’ is closed to new replies.