Support » Plugin: A2 Optimized WP » PHP Notice: Trying to get property of non-object

  • I’ve been debugging some sites and noticed they all have the same PHP Notice associated with this plugin:

    PHP Notice: Trying to get property of non-object in /home/SITE/public_html/wp-content/plugins/a2-optimized-wp/A2_Optimized_OptionsManager.php on line 1489

    Any idea on how to resolve this?

    Thanks,
    Sarah

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author A2 Hosting

    (@a2hosting)

    Hello,

    Which version of A2 Optimized are you running?

    Version 2.0.8.5. I just updated to 2.0.9 and will report back if I continue to see the notice.

    Thanks!
    S.

    I have updated to 2.0.9.1 and am now seeing the following notice, triggered when going to the A2 Optimized settings page:

    PHP Notice: Undefined index: plugin in /home/SITE/public_html/wp-content/plugins/a2-optimized-wp/A2_Optimized_OptionsManager.php on line 1291

    I updated like the plugin said and now enabling W3TC produces pages of garbled code until I refresh the page once (I’m assuming this caches it). on all my site pages

    �i�—��� pX���oxc�h����_���=�i �������aϣ�LT<���k���8��\{o�Ɩ�ߟb����^Q/�cK��&m.��E#r$MLr�G����b�]<code>���w������̐)˶��i�b�Z��q�3�=Ü|��������s6NàB��F=GD'b(g=G��</code>L?i��(n���Gf��I �ˍD=G��@����y,zN*fi���ac�99��t�T�T��&MO��i�z*JE����V(#9����
    

    The only way to return back to normal was to disable page caching!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP Notice: Trying to get property of non-object’ is closed to new replies.