Support » Plugin: Contact Form 7 - Post Fields » [PHP Notice] Thrown when using with CF7 4.6 or greater

  • Resolved sjmur

    (@sjmur)


    On Contact Form 7 4.6 and 4.7. PHP Notice is thrown.

    wpcf7_add_shortcode is deprecated since Contact Form 7 version 4.6! Use wpcf7_add_form_tag instead

    The plugin calls these methods in

    modules/checkbox.php line 36
    modules/select.php line 32

    Changing to wpcf7_add_form_tag on both resolves the issue.

    Please update the plugin, developer.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Markus Froehlich

    (@markusfroehlich)

    Thank you very much for your topic,
    the thrown notice should be disappeared in version 1.2.

    Best regards
    Markus Froehlich

    Hello Markus

    Thanks a lot for your awesome plugin!
    I use version 1.3, but the notices are still there :/

    Plugin Author Markus Froehlich

    (@markusfroehlich)

    Hello nikosmdtps,
    you get the same notice or a other?

    Best regards
    Markus Froehlich

    Hello Markus

    Thanks a lot for your response!

    This is the notice:
    Notice: WPCF7_Shortcode is DEPRECATED since Contact Form 7 version 4.6! Use WPCF7_FormTag instead. in /home/_______/public_html/wp-content/plugins/contact-form-7/includes/functions.php on line 357

    Plugin Author Markus Froehlich

    (@markusfroehlich)

    Thank you very much for your bug report.
    The thrown notice should be disappeared in the next version.

    Best regards
    Markus Froehlich

    Hello Markus

    You are welcome!
    Do you have an ETA for the next version?

    Plugin Author Markus Froehlich

    (@markusfroehlich)

    Yes, this week.
    With a brand new feature 🙂

    Best regards
    Markus Froehlich

    Plugin Author Markus Froehlich

    (@markusfroehlich)

    New update is out now 🙂

    Best regards
    Markus Froehlich

    Hello Markus

    Thanks a lot for the update.. Everything works as expected!
    Have a nice day 🙂

    Hi Markus! Thanks for the great plugin

    Just reporting: I am using 1.7.1, and the notice is back 🙂

    Plugin Author Markus Froehlich

    (@markusfroehlich)

    Hello, thank you for our report.
    I am in holiday now for one week, i will fix this notice as soon as possible 🙂
    Please write me here the full php notice.

    Best regards
    Markus Froehlich

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[PHP Notice] Thrown when using with CF7 4.6 or greater’ is closed to new replies.