Support » Plugin: Preview E-mails for WooCommerce » PHP Notice in PHP 7.0.x

  • Resolved Drivingralle

    (@drivingralle)


    Hey!

    I’m using version 1.2.6 of the plugin and get the following PHP notice for PHP 7.0.x and 7.1.x:
    Notice: Use of undefined constant PLUGIN_FILE_PATH – assumed ‘PLUGIN_FILE_PATH’ in /wp-content/plugins/woo-preview-emails/classes/class-woocommerce-preview-emails.php on line 66

    Also because of that the css and js added by the plugin breaks.
    <link rel=’stylesheet’ id=’woo-preview-email-select2-css-css’ href=’/wp-content/plugins/assets/css/select2.min.css?ver=4.7.5′ type=’text/css’ media=’all’ />

    I tried to create a Github issue but the plugin there is out of date with version 1.1.

    Greetings
    derRALF

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author digamberpradhan

    (@digamberpradhan)

    Hi Drivingralle,

    Thank you for pointing out the issue. I have fixed the issue and updated the plugin.

    As for not maintaining the git repo my apologies, I have started re-maintaining the plugin starting from version 1.2.7.

    Hey!

    Thanks for that super quick fix.
    Works great.

    Greetings
    derRALF

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP Notice in PHP 7.0.x’ is closed to new replies.