Support » Plugin: YITH WooCommerce Badge Management » PHP Notice in error log

  • JapeNZ

    (@japenz)


    Hi there,
    I’m seeing the following message in my debug log:

    PHP Notice: Array to string conversion in /wp-content/plugins/yith-woocommerce-badges-management/templates/badge_content.php on line 23

    Any idea what might be causing it?

    Thank for your help 🙂

    Kind regards,
    JP

    • This topic was modified 1 month ago by JapeNZ.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author YITHEMES

    (@yithemes)

    Hi there,

    Is WPML plugin active in your installation?
    We will add a fix in next plugin update to prevent this notice.
    You can simply ignore it for the moment.

    • This reply was modified 4 weeks, 1 day ago by YITHEMES.
    Plugin Author YITHEMES

    (@yithemes)

    Hi again,
    Please could you also provide us with the URL of the page(of your site) in which this issue occurs?

    Furthermore, could you try the following simple test?
    Try to deactivate all plugins, leaving only WooCommerce and YITH WooCommerce Badge Management active, and see if the problem is solved. If so, try to activate them again, one by one, to see which one causes the issue.

    Please try this solution and let us know what’s the result.

    JapeNZ

    (@japenz)

    Hi @yithemes,
    Thanks for looking in to this for me 🙂

    My website is www.comicbookshop.co.nz but the only page I have badges visible is here www.comicbookshop.co.nz/product-category/comic-book-subscriptions/ so I assume the message in my debug log is appearing only when this page is visited… though I may be wrong.

    I don’t use the WPML plugin.

    The site is a live business site so I’d rather not go through the ‘deactivate everything’ process unless it’s absolutely necessary.
    If you need any information from me so you can try and replicate the problem just ask 🙂

    Thanks again!

    Kind regards,
    JP

    Plugin Author YITHEMES

    (@yithemes)

    Hi there,
    unfortunately without being able to deactivate anything it is difficult to understand what causes that notice, you could try to create a clone site so that you can test it there

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.