WordPress.org

Forums

[resolved] PHP installation missing MySql. (13 posts)

  1. violettak
    Member
    Posted 9 years ago #

    When I'm trying to run the install script, I get this --

    "Your PHP installation appears to be missing the MySQL which is required for WordPress."

    Does this have to do with entering the incorrect information for my database or something that my hosting company needs to do?

  2. petit
    Member
    Posted 9 years ago #

    By the error message it woudl seem that you don't have any MySQL accessibel, but the message could be too insensitive.

    Some questions:
    Have you created a MySQL database for your WP blog? It might be nescessary, Your Service Provider will know.

    Have you given the correct database name, user and password in the wp-admin/wp-config.php ( renaming it from wp-config-sample.php )?

    Is this about WordPress 2.0?
    The famous 5-Minute Istall at http://codex.wordpress.org/Installing_WordPress#Famous_5-Minute_Install
    should work.

  3. Cypher
    Member
    Posted 9 years ago #

    For WP to work, you need you need the MySQL extentions to PHP installed. If you are on a Linux (RPM based) machine, then you specifically need the 'php' and 'php-mysql' packages.

    If you are trying this on a hosted site, then contact your provider about ensuring that they have the extentions installed.

    This has nothing to do with your database name, access, password, and so on. You're not there yet. :)

    Regards

  4. violettak
    Member
    Posted 9 years ago #

    Thanks! I have a ticket open with my hosting company, so hopefully it will get fixed soon. :)

  5. petit
    Member
    Posted 9 years ago #

    Cypher: Thanx for getting closer to the origin ;-)

  6. xadrian_calim
    Member
    Posted 9 years ago #

    What if you're running your own Win2003/IIS server? I ran through all the preinstallation.

    Another (off topic question,) not knowing a lot of MySQL, when I'm at the prompt (mysql>) and I enter all the create database commands, shouldn't I get something saying it's done? It either goes back to prompt or gives me a syntax message.

    (noob)

  7. Cypher
    Member
    Posted 9 years ago #

    If you're on Windows, you'd want to make sure that mysql support is enabled in PHP. You can get that information from writing a simple file that called "phpinfo();" and make sure that you see: "MySQL Support enabled".

    In MySQL itself, some functions work without any output, all errors are reported and certain commands, like UPDATE, INSERT, and so on will output how many rows were affected by your command.

    Regards

  8. xadrian_calim
    Member
    Posted 9 years ago #

    Hmm, I've got that line uncommented, saved in C:\PHP and C:\Windows\system32 but I can't find that bit enabled on the page.

    I'll keep working on it.

  9. peibul
    Member
    Posted 9 years ago #

    I have the same problem (i.e. "Your PHP installation appears to be missing...").

    I've already installed MySql 5.0 + MySql Administrator, but the webpage generated with phpinfo() doesn't show any message saying "MySQL Support enabled", though it includes, in its path variable, the location of the bin's for MySql (i.e. "C:\Program Files\MySQL\MySQL Server 5.0\bin")

    I've already created a database for WP, and placed its name in wp-config.php.

    MySQL extentions to PHP installed? Where do I get these?

    I have a Windows machine running as a server for Intranet purposes - hence, no host provider :(

  10. DaNewYorker
    Member
    Posted 9 years ago #

    Spent some time on this problem and here is how I solved it.

    1. I used the PHP installer which does not contain all of the dlls and I was getting the error discussed.

    2. I downloaded the windows zip file -> PHP 5.1.1 zip package ( http://us2.php.net/downloads.php )

    3. I copied the /ext folder from the zip file into my c:\php folder (now those files are in c:\php\ext)

    4. I copied all the DLLs from the root of the Zip file to my c:\php folder. The ext files have some dependencies on these files so I copied them all to be safe.

    5. I changed the value in c:\windows\php.ini (this may be in a different location on your machine) for extensions to say -> extension_dir = "c:\php\ext\"

    6. I removed the commments from the extensions section so the MySQL settings showed as:

    extension=php_mysql.dll
    extension=php_mysqli.dll

    The mysqli.dll is supposed to be used for MySQL 5.0+ i believe... so i made sure both were in there. I believe the original ini file didn't have php_mysqli.dll listed and I had to add it myself.

    After these steps it worked for me. I did have to add index.php to my default documents list for IIS (and i assume you would do the same in apache). I also had some database creation errors related to default values not being set by scripts but for the most part WordPress is up and running.

  11. peibul
    Member
    Posted 9 years ago #

    DaNewYorker: Thank you so much! I never noticed the line "extension=php_mysqli.dll" wasn't even there!

    Cheers mate!

  12. xadrian_calim
    Member
    Posted 9 years ago #

    I'll be going through these steps as well DNY, thanks.

  13. violettak
    Member
    Posted 9 years ago #

    I changed my hosting company from godaddy and it works smoothly now! :)

Topic Closed

This topic has been closed to new replies.

About this Topic