WordPress.org

Forums

Php files not updating. (8 posts)

  1. ThoughtsFrog
    Member
    Posted 9 years ago #

    When I edit my PHP files via the dashboard, like the titles of stuff, or adding more BIO info, when I go to view my website it does not appear. When I click the archives, or the comments of a post, I see the changes until I go back to the main homepage. What is going on? Basically if you click around on my website right now the sidebar frantically changes for each page.

  2. mylagoon
    Member
    Posted 9 years ago #

    Basically if you click around on my website right now the sidebar frantically changes for each page.

    I would, except I don't know your website's URL. Sounds like your theme isn't coded how you want it to be.

  3. ThoughtsFrog
    Member
    Posted 9 years ago #

    It happens with every theme, I'm thinking its my hosting.

    EDIT: Woah, I made a post and it fixed itself. Problem solved? Hha. Thanks mylagoon.

  4. jennt1111
    Member
    Posted 9 years ago #

    I'm new to WordPress, & I'm having the same problems. How do you get changes to take (like updating or making changes to the theme or adding links, etc.) ? It seems the only way I can get changes to take effect is to add or edit a post & save the post - then all my other changes get applied. Is there a place you can "publish" changes that you made?

    I'm using the Dixie Bell theme I got from alexking.org, which I've customized a bit, but didn't make any major changes to code - just some images.

    http://blog.jmt-art.com

  5. Chris_K
    Member
    Posted 9 years ago #

    Try refreshing your local browser's cach with CTRL+F5.

  6. jennt1111
    Member
    Posted 9 years ago #

    I've refreshed in every way I can & it's still not updating unless I go into write a post & save a new post or edit & save an old one. I use Firefox, but I've also opened the blog in IE and refreshed there, too. I've done the Refresh button on the browser & a hard refresh with Ctrl+F5 - still not updating.

  7. Samuel B
    moderator
    Posted 9 years ago #

    Pretty site.
    For posts not saved:
    What plugins do you have activated? Maybe a conflict? If so, maybe disable them one by one and test. Start with any stats plugin.

    "like updating or making changes to the theme or adding links, etc."

    This stuff is totally different.
    To edit themes (theme files) in the theme editor, all theme files must be CHMOD 666 to be able to save changes. Don't leave at this, though for security - change back to 644.

    Adding links?
    Where do you want them? In posts? If so, disable wysiwyg editor any time you want to insert code. It doesn't like code very much. :>)

  8. jennt1111
    Member
    Posted 9 years ago #

    OK, I think you lost me.

    Plugins - I don't have any activated that I know of. I didn't install any.

    Yes - theme editing - that's what's not updating. You've lost me at the CHMOD 666 and change back to 644. So is there something special I need to do or look for in my theme editor to make changes work?

    Adding links - to the sidebar is where I was adding them. I was just adding them to the Blogroll & then I changed the category names & it wasn't updating them. When I'd click the "View Site" link after updating the changes, it would look OK, but then when I'd manually type in the blog address, it would have the old stuff.

    Thanks for your help - I think I can get this figured out - just needs a little work!

Topic Closed

This topic has been closed to new replies.

About this Topic