Support » Plugin: WooCommerce ShipStation Integration » PHP Fatal error upon upgrade to WooCommerce

  • Resolved splaquet

    (@splaquet)


    I upgraded to WooCommerce 3.5 yesterday on one of my dev installations. The site crashed after the update and this was the only error in the log.

    [23-Oct-2018 20:18:43 UTC] PHP Fatal error: Class ‘WC_Integration’ not found in /home/../public_html/../../plugins/woocommerce-shipstation-integration/includes/class-wc-shipstation-integration.php on line 10

Viewing 13 replies - 1 through 13 (of 13 total)
  • Same problem.
    Fatal error: Class ‘WC_Integration’ not found in /home/coolin6/public_html/myheatsinks.com/store/wp-content/plugins/woocommerce-shipstation-integration/includes/class-wc-shipstation-integration.php on line 10

    Thread Starter splaquet

    (@splaquet)

    @tlqmhs… it’s a bit concerning that I/we haven’t heard anything from the plugin team, in a few days :/

    @splaquet
    I posted an issue on woocommerce github and got replied by their staff, said the problem has been transfer to ShipStation extension team.
    https://github.com/woocommerce/woocommerce/issues/21676

    Plugin Support Job a11n

    (@jobthomas)

    Automattic Happiness Engineer

    Hey @tlqmhs – thanks for opening that issue.

    So far our developers haven’t been able to reproduce this yet, as you can read here: https://github.com/woocommerce/woocommerce/issues/21676 – we’re still looking into it. I’ve tested it myself and am not able to reproduce it.

    As to rolling back, if your host does backups (or you had your own back system installed), you can go back in time for the setup. Getting your system status, as indicated on the GH issue would help us find out what happened.

    If you don’t have backups, you can go to your FTP client (or use cPanel or whatever software your hosting company uses). Temporarily delete the ShipStation plugin under wp-content/plugins there (or just change the name). You can update that later. Ideally, your site would’ve been backed up before.

    Once you’ve done that you’ll be able to log into your site again. You can then go back to a previous version of WooCommerce. For example, through the WP Rollback plugin (again, please make a backup first).

    • This reply was modified 2 years, 12 months ago by Job a11n.
    Thread Starter splaquet

    (@splaquet)

    I posted this on GitHub. Wasn’t sure if it was noticed.

    ###

    I submitted one of the Fatal Error reports on the WordPress plugin page. Fortunately, I first activated the plugin on a /dev site. I disabled the plugin to resume working on the site.

    Also worth noting, that line was the only error that was posted into the error log.

    Here’s some background on my install:

    – multisite sub-domain install
    – WooGlobalCart
    – WooMultiSite

    Those are the only non-standard elements I can think of. The rest of the plugins are widely used. I can submit a full list of extensions, if needed.

    Plugin Support Job a11n

    (@jobthomas)

    Automattic Happiness Engineer

    Thanks for the update @splaquet – please continue this on the GitHub repo since that’s where our developers also hang around. Maybe update your comment to include the system status there?

    Thread Starter splaquet

    (@splaquet)

    I was able to successfully activate the plugin. When I initially upgraded WooCommerce, the database upgrades/update hadn’t been performed on the subsites. I updated all of the subsites… but hadn’t had a chance to truly troubleshoot the install until today.

    I deactivated all of the plugins, reactivating them a few at a time. Surprisingly, everything activated without issues. Nothing in the debug.log either.

    I’d like to believe that was it… that it wasn’t compatible with the old WooCommerce subsite tables. I believe that the only difference was that the tables had been updated before reactivating the plugin.

    Thread Starter splaquet

    (@splaquet)

    not sure if this is relevant or not… but, i saw that my child theme had out of date woocommerce templates (was actually the parent theme). i went to see which files were outdated and saw several several database warnings, “Table does not exist”. I’m not sure if this is an actual error or an oversight on the update.

    So, i went to disable WooCommerce, thinking that network reactivating it would rebuild those missing tables. upon deactivation of WooCommerce, the site crashed again. (due to shipstation not auto-deactivating). I renamed the shipstation plugin folder, got the site back up, reactivated WooCommerce, then reactivated shipstation.

    everything was back up and works again, but those table errors are still present in all of my subsites’ WooCommerce status pages.

    Total Database Size	 	12.78MB
    Database Data Size	 	11.82MB
    Database Index Size	 	0.96MB
    hlmu_4_woocommerce_sessions	 	 Table does not exist
    hlmu_4_woocommerce_api_keys	 	 Table does not exist
    hlmu_4_woocommerce_attribute_taxonomies	 	 Table does not exist
    hlmu_4_woocommerce_downloadable_product_permissions	 	 Table does not exist
    hlmu_4_woocommerce_order_items	 	 Table does not exist
    hlmu_4_woocommerce_order_itemmeta	 	Data: 0.02MB + Index: 0.03MB
    hlmu_4_woocommerce_tax_rates	 	 Table does not exist
    hlmu_4_woocommerce_tax_rate_locations	 	 Table does not exist
    hlmu_4_woocommerce_shipping_zones	 	 Table does not exist
    hlmu_4_woocommerce_shipping_zone_locations	 	 Table does not exist
    hlmu_4_woocommerce_shipping_zone_methods	 	 Table does not exist
    hlmu_4_woocommerce_payment_tokens	 	 Table does not exist
    hlmu_4_woocommerce_payment_tokenmeta	 	Data: 0.02MB + Index: 0.03MB
    hlmu_4_woocommerce_log	 	 Table does not exist
    hlmu_4_commentmeta	 	Data: 0.02MB + Index: 0.03MB
    hlmu_4_comments	 	Data: 0.02MB + Index: 0.09MB
    hlmu_4_links	 	Data: 0.02MB + Index: 0.02MB
    hlmu_4_options	 	Data: 1.11MB + Index: 0.05MB
    hlmu_4_postmeta	 	Data: 2.52MB + Index: 0.25MB
    hlmu_4_posts	 	Data: 0.23MB + Index: 0.06MB
    hlmu_4_termmeta	 	Data: 0.02MB + Index: 0.03MB
    hlmu_4_terms	 	Data: 0.02MB + Index: 0.03MB
    hlmu_4_term_relationships	 	Data: 0.02MB + Index: 0.02MB
    hlmu_4_term_taxonomy	 	Data: 0.02MB + Index: 0.03MB
    hlmu_4_woocommerce_bundled_itemmeta	 	Data: 0.02MB + Index: 0.03MB
    hlmu_blogs	 	Data: 0.02MB + Index: 0.03MB
    hlmu_blog_versions	 	Data: 0.02MB + Index: 0.02MB
    hlmu_registration_log	 	Data: 0.02MB + Index: 0.02MB
    hlmu_signups	 	Data: 0.02MB + Index: 0.06MB
    hlmu_site	 	Data: 0.02MB + Index: 0.02MB
    hlmu_sitemeta	 	Data: 7.20MB + Index: 0.03MB
    hlmu_usermeta	 	Data: 0.44MB + Index: 0.03MB
    hlmu_users	 	Data: 0.02MB + Index: 0.05MB

    here’s a screenshot:
    https://www.dropbox.com/s/rgv17vfqifs87mn/WooCommerce_MissingTables.jpg?dl=0

    Just to confirm, I have the same problem. My entire site crashed on upgrade to 3.5.0, and I didn’t immediately know why. My ISP searched the logs and found a Woocommerce-Shipstation plugin error. They renamed the plugin by adding a .bak to it, thereby disabling it, and the web site came back up – without Woocommerce. I re-enabled Woocommerce and it worked, without Shipstation.

    At this point I am inputting my shipments into Shipstation manually, rather than using the Woocommerce plugin.

    Not sure if this is the right place to post but yes we had the exact same issue. Entire site crashed and had to perform a backup to restore the site when upgrading to 3.5.1. It actually works with 3.5. Can’t update Woocommerce to newest version because of this.

    Thread Starter splaquet

    (@splaquet)

    wow… that’s a true bummer. i only had to deactivate/reactivate to get my site back up.

    Plugin Support Doug – a11n

    (@dougaitken)

    Automattic Happiness Engineer

    Hey all,

    We have released version 4.1.25 for the ShipStation integration.

    I’d recommend updating WooCommerce first (to also ensure compatibility with WordPress 5.0) and then updating the ShipStation plugin.

    If you have problems, you may also need to rename the ShipStation plugin folder or reinstall the extension. You can read about this issue here – https://wordpress.org/support/topic/error-updating-to-4-1-23

    Let me know how you are getting on.

    Thanks,

    Come on now guys, fix this damn problem! My site is running 4.1.26 and I am still experiencing the same error:

    PHP message: PHP Fatal error: Class ‘WC_Integration’ not found in /wp-content/plugins/woocommerce-shipstation-integration/includes/class-wc-shipstation-integration.php on line 10

    You guys need to fix your software because releasing it!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘PHP Fatal error upon upgrade to WooCommerce’ is closed to new replies.