Support » Plugin: Debug Objects » PHP Fatal error: Uncaught Error: Call to undefined function settings_fields()

  • Hi,

    Trying to click on the Debug link right after installing your plugin on PHP 7.0 results in the following error:

    [09-Feb-2017 23:34:34 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function settings_fields() in /home/USER/ftp/www.DOMAIN.com/public_html/wp-content/plugins/debug-objects/inc/autoload/class-settings.php:237
    Stack trace:
    #0 /home/USER/ftp/www.DOMAIN.com/public_html/wp-content/plugins/debug-objects/inc/class-wrap.php(54): Debug_Objects_Settings::return_options()
    #1 /home/USER/ftp/www.DOMAIN.com/public_html/wp-content/plugins/debug-objects/debug-objects.php(237): Debug_Objects_Wrap->__construct()
    #2 /home/USER/ftp/www.DOMAIN.com/public_html/wp-content/plugins/debug-objects/debug-objects.php(127): Debug_Objects->init_classes()
    #3 /home/USER/ftp/www.DOMAIN.com/public_html/wp-content/plugins/debug-objects/inc/autoload/class-settings.php(43): Debug_Objects->__construct()
    #4 /home/USER/ftp/www.DOMAIN.com/public_html/wp-content/plugins/debug-objects/inc/autoload/class-settings.php(646): Debug_Objects_Settings->__construct()
    #5 /home/USER/ftp/www.DOMAIN.com/public_html/wp-content/p in /home/USER/ftp/www.DOMAIN.com/public_html/wp-content/plugins/debug-objects/inc/autoload/class-settings.php on line 237

    Would appreciate a fix 🙂

    Best,
    Chris Trynkiewicz

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi,

    Did you find any solution to the problem? Same issue happened to me!

    Fatal error: Uncaught Error: Call to undefined function settings_fields() in /home/webfish0/public_html/wp-content/plugins/debug-objects/inc/autoload/class-settings.php:237 Stack trace: #0 /home/webfish0/public_html/wp-content/plugins/debug-objects/inc/class-wrap.php(54): Debug_Objects_Settings::return_options() #1 /home/webfish0/public_html/wp-content/plugins/debug-objects/debug-objects.php(237): Debug_Objects_Wrap->__construct() #2 /home/webfish0/public_html/wp-content/plugins/debug-objects/debug-objects.php(127): Debug_Objects->init_classes() #3 /home/webfish0/public_html/wp-content/plugins/debug-objects/inc/autoload/class-settings.php(43): Debug_Objects->__construct() #4 /home/webfish0/public_html/wp-content/plugins/debug-objects/inc/autoload/class-settings.php(646): Debug_Objects_Settings->__construct() #5 /home/webfish0/public_html/wp-content/plugins/debug-objects/debug-objects.php(144): require_once('/home/webfish0/...') #6 /home/webfish0/public_html/wp-content/plugins/debug-objects/debug-objects.php(122): Debug_Ob in /home/webfish0/public_html/wp-content/plugins/debug-objects/inc/autoload/class-settings.php on line 237

    Hi,

    Nope, no solution yet.

    Plugin Author Frank

    (@bueltge)

    The current master of the development version should work, can you test it?
    You can download this master version here: https://github.com/bueltge/debug-objects/archive/master.zip

    Hello Frank,

    Unfortunately the site which the bug occurred on is a large store, so we can’t use it for any testing purposes. Perhaps @dchatzimanolis could verify?

    Best,
    Chris

    Hello Frank,

    I installed and activated master version but I still get the same error :

    Fatal error: Call to undefined function settings_fields() in /public_html/wp-content/plugins/debug-objects-master/inc/autoload/class-settings.php on line 237

    Waiting for your recommendations.

    Simply breaks.
    In my debug.log (wp 4.7.2 & plugin from repository)

    [01-Mar-2017 01:19:10 UTC] PHP Fatal error: Call to undefined function settings_fields() in /home/ilumilab/public_html/wp-content/plugins/debug-objects/inc/autoload/class-settings.php on line 237

    same here with latest and master version!

    Plugin Author Frank

    (@bueltge)

    The new version 2.4.1 is now live and should be fixed that.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘PHP Fatal error: Uncaught Error: Call to undefined function settings_fields()’ is closed to new replies.