Support » Localhost Installs » PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in

  • Resolved sbsmain

    (@sbsmain)



    I installed php 7.2 and have since gotten this error:
    PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in C:\inetpub\wwwroot\wp-includes\wp-db.php:1564

    I’ve googled it and tried several things, but nothing seems to work. I’m new to this, so, I could use some help. If I reinstall WordPress, what folders would I need to replace to get my website going again?

    Mike in SC

Viewing 7 replies - 1 through 7 (of 7 total)
  • WordPress itself supports PHP 7.2 (at least I assume you are using a fairly recent version of WP). Make sure your environment has either MySQL 5.6+ or MariaDB 10+.

    Please check your wp-config.php file for the following line:

    define('WP_USE_EXT_MYSQL', true);

    If you find it, delete the line. Your problem should be fixed.

    If you still have the problem, then you incorrectly installed PHP 7.2.x. The error you reported is not possible if you are using PHP 7.2.x and the above line isn’t in wp-config.php.

    Installing Mariadb 10.3 fixed this.

    I can now view my webpage in localhost and access it from other computers on my domain, but the graphics don’t disply on the other computers. The problem is my path is pointed to localhost. So, I’m currently trying to login to the wordpress dashboard, but it doesn’t give me that option. Any ideas?

    • This reply was modified 4 months, 1 week ago by  sbsmain.

    I’ll mark this one resolved and post the new issue.

    For what is worth, I encountered the same error and the issue was solved by enabling the nd_mysqli extension in the PHP 7 configuration, and disabling the mysqli one.

    Thanks Francesco! I did as you said and the error was solved (enabled nd_mysqli, the mysqli was already disabled).
    I was using PHP 7 since months, so I don’t know why the error happened (today) in the first place?

    Glad it helped!

    I encountered the error when I upgraded to PHP 7 while having the W3 Total Cache “Database cache” enabled.

    Maybe you’ve played around with W3TC today?

    See for reference: https://wordpress.org/support/topic/database-cache-causing-503-errors-when-upgrading-to-php-7/

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.