WordPress.org

Support

Support » Plugins and Hacks » Contact Form 7 Honeypot » [Resolved] PHP Fatal Error on update to v1.6

[Resolved] PHP Fatal Error on update to v1.6

  • Hi there,

    When I try to update CF7 Honeypot from version 1.1 to 1.6, I get the following PHP Fatal error on any page with the [honeypot] shortcode:

    PHP Fatal error: Class ‘WPCF7_Shortcode’ not found in C:\<directory of my site>\wp-content\plugins\contact-form-7-honeypot\honeypot.php on line 59

    I am running WP 3.5

    Thanks!

    Darren

    https://wordpress.org/plugins/contact-form-7-honeypot/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Ryan

    @daobydesign

    Hi Darren, are you sure you’re running the latest version of Contact Form 7? It sounds like you might be using an older version of CF7. That will need to be updated to the latest version to work with the latest version of this CF7 module.

    Hi Ryan,

    I’ve got CF7 version 3.3.3 installed. Although I know it’s not the most recent version, I have no update notification for that plugin – maybe because I’m only running WP 3.5?

    Darren

    Plugin Author Ryan

    @daobydesign

    That’s likely it. If there’s nothing stopping you from upgrading WordPress, you definitely should and then upgrade CF7 to the latest version (3.8). If you need to stay where you’re at, you’ll need to roll your CF7 Honeypot version back to v1.3.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] PHP Fatal Error on update to v1.6’ is closed to new replies.
Skip to toolbar