WordPress.org

Forums

Contact Form 7 Honeypot
[resolved] PHP Fatal Error on update to v1.6 (4 posts)

  1. dmpinder
    Member
    Posted 1 year ago #

    Hi there,

    When I try to update CF7 Honeypot from version 1.1 to 1.6, I get the following PHP Fatal error on any page with the [honeypot] shortcode:

    PHP Fatal error: Class 'WPCF7_Shortcode' not found in C:\<directory of my site>\wp-content\plugins\contact-form-7-honeypot\honeypot.php on line 59

    I am running WP 3.5

    Thanks!

    Darren

    https://wordpress.org/plugins/contact-form-7-honeypot/

  2. Ryan
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Darren, are you sure you're running the latest version of Contact Form 7? It sounds like you might be using an older version of CF7. That will need to be updated to the latest version to work with the latest version of this CF7 module.

  3. dmpinder
    Member
    Posted 1 year ago #

    Hi Ryan,

    I've got CF7 version 3.3.3 installed. Although I know it's not the most recent version, I have no update notification for that plugin - maybe because I'm only running WP 3.5?

    Darren

  4. Ryan
    Member
    Plugin Author

    Posted 1 year ago #

    That's likely it. If there's nothing stopping you from upgrading WordPress, you definitely should and then upgrade CF7 to the latest version (3.8). If you need to stay where you're at, you'll need to roll your CF7 Honeypot version back to v1.3.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Contact Form 7 Honeypot
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.