Support » Plugin: WooCommerce Currency Switcher by PluginUs.NET. Woo Multi Currency and Woo Multi Pay » PHP Fatal error: Maximum execution time of 30 seconds exceeded

  • Resolved rickbase1

    (@rickbase1)


    I keep getting locked out of my site and I am getting lots of these error messages in my error log.

    Please advise
    Thanks

    [Tue May 14 10:41:26.699485 2019] [proxy_fcgi:error] [pid 505:tid 140368105228032] [client 66.249.146.218:47766] AH01071: Got error ‘PHP message: PHP Fatal error: Maximum execution time of 30 seconds exceeded in /ebs2/vhosts/backstagesailing.com/offgridsoftwaresolutions.com/wp-content/plugins/woocommerce-currency-switcher/classes/woocs_after_33.php on line 4236\n’, referer: https://offgridsoftwaresolutions.com/checkout/
    [Tue May 14 10:41:37.208081 2019] [proxy_fcgi:error] [pid 4117:tid 140368172369664] [client 66.249.146.218:47770] AH01071: Got error ‘PHP message: PHP Fatal error: Maximum execution time of 30 seconds exceeded in /ebs2/vhosts/backstagesailing.com/offgridsoftwaresolutions.com/wp-content/plugins/woocommerce-currency-switcher/classes/woocs_after_33.php on line 4236\n’, referer: https://offgridsoftwaresolutions.com/checkout/
    [Tue May 14 10:42:24.349991 2019] [proxy_fcgi:error] [pid 505:tid 140368088442624] [client 162.212.14.110:56273] AH01071: Got error ‘PHP message: PHP Fatal error: Maximum execution time of 30 seconds exceeded in /ebs2/vhosts/backstagesailing.com/offgridsoftwaresolutions.com/wp-content/plugins/woocommerce-currency-switcher/classes/woocs_after_33.php on line 4236\n’, referer: https://offgridsoftwaresolutions.com/checkout/
    [Tue May 14 10:43:42.262075 2019] [proxy_fcgi:error] [pid 505:tid 140368063264512] [client 162.212.14.110:62610] AH01071: Got error ‘PHP message: PHP Fatal error: Maximum execution time of 30 seconds exceeded in /ebs2/vhosts/backstagesailing.com/offgridsoftwaresolutions.com/wp-content/plugins/woocommerce-currency-switcher/classes/woocs_after_33.php on line 4234\n’, referer: https://offgridsoftwaresolutions.com/checkout/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello

    Try in file – /wp-content/plugins/woocommerce-currency-switcher/classes/woocs_after_33.php – to comment this line – https://c2n.me/41yFt3l.png

    what version of the plugin do you use?

    Thank you for the information. I commented out the line and it seems to stop the timeout issue, but I have larger plugin integration issues. After adding a couple of new plugins my alternate currency no longer calculates properly so I have disabled the plug in for the time being and may just stick with a single currency for now.

    My plugin version 1.2.8.1

    Kind regards

    Rick

    Hello @rickbase1.

    Please activate the plugin and drop me link to the issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP Fatal error: Maximum execution time of 30 seconds exceeded’ is closed to new replies.